<div dir="ltr"><div>Hey guys,</div><div><br></div><div>I've got a bit of a sticky error. I don't have any native code in this particular application, but what I'm seeing is after some time of running (this is a server-side app running via upstart on Ubuntu), I get this nasty error.<br></div><div><br></div><div>* Assertion at metadata.c:965, condition `idx < t->rows' not met</div><div><br></div><div>Stacktrace:</div><div><br></div><div>  at <unknown> <0xffffffff></div><div>  at (wrapper managed-to-native) System.Reflection.MonoMethodInfo.get_parameter_info (intptr,System.Reflection.MemberInfo) <0xffffffff></div><div>  at System.Reflection.MonoMethodInfo.GetParametersInfo (intptr,System.Reflection.MemberInfo) <0x00011></div><div>  at System.Reflection.MonoMethod.GetParametersInternal () <0x00013></div><div>  at System.Exception.GetFullNameForStackTrace (System.Text.StringBuilder,System.Reflection.MethodBase) <0x0002d></div><div>  at System.Exception.AddFrames (System.Text.StringBuilder,string,string,System.Diagnostics.StackTrace) <0x00174></div><div>  at System.Exception.get_StackTrace () <0x00158></div><div>  at System.Exception.ToString () <0x000fc></div><div>  at (wrapper runtime-invoke) <Module>.runtime_invoke_object__this__ (object,intptr,intptr,intptr) <0xffffffff></div><div><br></div><div>Native stacktrace:</div><div><br></div><div>        mono() [0x4b20bc]</div><div>        /lib/x86_64-linux-gnu/libpthread.so.0(+0x10340) [0x7fd05dd3b340]</div><div>        /lib/x86_64-linux-gnu/libc.so.6(gsignal+0x39) [0x7fd05d99ccc9]</div><div>        /lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7fd05d9a00d8]</div><div>        mono() [0x6294f9]</div><div>        mono() [0x629707]</div><div>        mono() [0x629856]</div><div>        mono(mono_metadata_decode_row+0xd3) [0x55d503]</div><div>        mono(mono_method_get_param_names+0x224) [0x546ec4]</div><div>        mono() [0x5c5294]</div><div>        [0x416b4e28]</div><div><br></div><div>Debug info from gdb:</div><div><br></div><div><br></div><div>=================================================================</div><div>Got a SIGABRT while executing native code. This usually indicates</div><div>a fatal error in the mono runtime or one of the native libraries</div><div>used by your application.</div><div>=================================================================</div><div><br></div><div>Anyone have any suggestions on what might be causing this or something I can do to avoid it?</div><div><br></div>-- <br><div class="gmail_signature"><div dir="ltr">Jerod Venema<div><br><div><font size="1"><b>Frozen Mountain Software</b><br>919-300-5141 (United States)<br></font><div><font size="1">604-227-2453 (Canada)</font></div><div><font size="1">888-379-6686 (Toll Free)<br></font></div><div><a href="http://www.frozenmountain.com" target="_blank"><font size="1">www.frozenmountain.com</font></a></div></div></div></div></div>
</div>