<div dir="ltr">This is caused because your mono was built with a bad TLS model and the runtime is unable to find<div>the required offset.</div><div><br></div><div>Rebuild it using --with-tls=pthread should workaround your issue until someone figures out what's wrong with</div><div>your setup.</div><div><br></div><div>On mixed mode debugging. It's incredibly complicated and there are no plans to support it in the immediate future.</div><div><br></div><div>--</div><div>Rodrigo</div><div><br><div><br></div><div><br></div></div></div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Aug 4, 2015 at 3:26 AM,  <span dir="ltr"><<a href="mailto:Jean-Michel.Perraud@csiro.au" target="_blank">Jean-Michel.Perraud@csiro.au</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I have an R package with embedded Mono, on Linux, that is working on Mono 3.12.x series but broken since  Mono 4.0.x.<br>
Crashes with:<br>
    Assertion at sgen-alloc.c:774, condition `tlab_next_addr_offset != -1' not met<br>
<br>
Repro and details at <a href="https://github.com/jmp75/rClr/issues/7" rel="noreferrer" target="_blank">https://github.com/jmp75/rClr/issues/7</a>, but optional for this present question.<br>
<br>
What I am after is to step in debug mode through Mono, to diagnose and hopefully figure out a fix, but could not find a procedure to:<br>
<br>
* build/install mono from source (I know that) but with debug symbols<br>
* If the above is done, can I use MonoDevelop or other graphical front-end to attach to the process with embedded Mono and step through code with GDB. I can already attach  MonoDevelop to the R process and catch the crash, but the call stack is devoid of info and reference to the source code (presumably lacking the former debug symbols?)<br>
<br>
Any advice on how to go about it is welcome. I hope we can do better than command line gdb.<br>
<br>
Cheers<br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" rel="noreferrer" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
</blockquote></div><br></div>