<div dir="ltr">Heya,<div><br></div><div>If you package Mono.Posix.dll your app *will crash* on different systems. This binary is platform specific and is not safe to copy between OS's. It is also matched with a platform specific native binary, libmonoposixhelper.[dll|dylib|so], which cannot be copied/pasted across platforms either. If you have a Mono.Posix.dll from one version of mono and a libmonoposixhelper.[dylib|so|dll] from another mono installation, that will crash too every time p/invoke signatures change, or other implementation details change.<div><br></div><div>It's fine to have a copy of Mono.Posix.dll used purely for compilation purposes. But at runtime you have to use the system provided one, which typically means the one provided by the system's mono installation.</div><div><br></div><div>Hope that helps!</div></div></div>