<div dir="ltr">Hi Chris,<div><br></div><div>I don't think we are keeping this counters up to date in the threadpool. Some of them are kept up to date, but as we imported the threadpool implementation from referencesources since 4.2, we must have missed this performance counter. So you are certainly not doing something wrong.</div><div><br></div><div>If you want, you should fill a bug with the information you have so we have a look at it as soon as possible.</div><div><br></div><div>Thank you very much,</div><div>Ludovic</div></div><br><div class="gmail_quote"><div dir="ltr">On Mon, May 23, 2016 at 11:59 PM Chris Swiedler <<a href="mailto:cswiedler@trionworlds.com">cswiedler@trionworlds.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Per <a href="https://bugzilla.xamarin.com/show_bug.cgi?id=1772" rel="noreferrer" target="_blank">https://bugzilla.xamarin.com/show_bug.cgi?id=1772</a> I've been trying to get Mono threadpool metrics with lines like this:<br>
<br>
    m_workItemsAdded = new PerformanceCounter("Mono Threadpool", "Work Items Added", Process.GetCurrentProcess().Id.ToString());<br>
<br>
However, the counter I get back always has its value set to zero. Are these threadpool counters still supported? Am I doing something wrong? This is using mono 4.2.3.<br>
<br>
Thanks,<br>
chris<br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com" target="_blank">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" rel="noreferrer" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
</blockquote></div>