[Mono-list] Mono downloads via YaST

Peter Bradley P.Bradley at dsl.pipex.com
Fri Jun 1 14:51:57 EDT 2007


I have SuSE 10.0 running on an HP AMD64 x 2 box and I would really like 
to get hold of the latest versions of Mono and Monodevelop.

On the downloads page for the 64 bit version, there are instructions as 


This distro supports installing packages via YaST. Add the following 
installation source to YaST:

    * http://go-mono.com/download-stable/suse-100-x86_64

For assistance with using repositories and installing packages with 
YaST, visit this link: [1] 


The url appears to be a reference to the page on which it appears - i.e. 
it is self-referential.  Neither does it appear to work in YaST: for me, 
at any rate.  Here's what I tried:

In YaST --> Software --> Installation Source, I clicked on add --> http 
and, in the dialog that appears added the following details:

Server Name: go-mono.com
Directory on server: download-stable/suse-100-x86_64

After clicking OK in the dialog, it went away and thought about it for a 
while and then added 27 identical URLs to the list in the Software 
source media dialog.  The URLs added are all listed (immediately after 
the line specifying my installation DVD source) as:


(which, I guess, is what you'd expect except that I was only expecting 
it to add a single line)

I then turned refresh on for each of these entries and clicked Finish.

Back in the YaST Control Centre I chose Software Management.  YaST then 
tried to refresh each of these sources.  On every attempt, the error 


was displayed.  Very user friendly, I thought :-)

When I eventually got back to YaST, nothing from this installation 
source appeared to be displayed (i.e. there was nothing I could see that 
indicated that I had any version of Mono available to me except 1.1.8x 
that I had from the installation DVD, and which I had uninstalled prior 
to adding the new source).  The source column in YaST was empty in all 

Finally, just for the heck of it, I turned refresh off and tried again.  
The result was the same.

Does anyone know what the undoubtedly obvious thing is that I've 
missed?  I've also posted to the opensuse list, in case it's a YaST 
problem.  Hopefully these two lists don't overlap sufficiently for this 
to be a problem.  Please let me know if it is, and I'll kill one of the 



More information about the Mono-list mailing list