Does anyone have any idea what this mono error message means on my Fedora 5 box?<br>&gt;Corlib not in sync with this runtime: expected corlib version 49, found 54.<br><br>I see the message when I try running an app I mkbundled on the same box.&nbsp; <br><br>At one time, I had a previous version of mono installed (1.13 I think) and then reinstalled by compiling from 1.1.17 source.&nbsp; <br><br>Thanks for any advice,<br><br>--Travis<br><br><br><b><i>Travis Staloch &lt;twostepted@yahoo.com&gt;</i></b> wrote:<blockquote class="replbq" style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;"> Robert,<br><br>Thanks again for your help.&nbsp; mkbundle was able to complete on my linux box, creating an .out file which I renamed to .exe and tried to run it.&nbsp; I get an error relating to the expected mscorlib version.&nbsp; Here it is<br>&gt; ./MyInstallerBundle.exe<br>Corlib not in sync with this runtime: expected corlib version 49, found
 54.<br>Download a newer corlib or a newer runtime at http://www.go-mono.com/daily.<br><br>Any ideas?<br><br>--Travis<br><br><b><i>Robert Jordan &lt;robertj@gmx.net&gt;</i></b> wrote:<blockquote class="replbq" style="border-left: 2px solid rgb(16, 16, 255); margin-left: 5px; padding-left: 5px;"> Hi Travis,<br><br>I'm not sure whether any non-critical (critical as in security,<br>data loss, etc.) patches will be accepted for the stable (1.1.13)<br>branch, but I'll try to get them in.<br><br>Robert<br><br>Travis Staloch wrote:<br>&gt; Thanks alot Robert.  I was wondering if I should use that one.  BTW,<br>&gt; did you mention when  that version of mkbundle.exe will be applied to<br>&gt; the current stable mono branch?<br>&gt; <br>&gt; --Travis<br>&gt; <br>&gt; Robert Jordan <robertj@gmx.net> wrote: Hi Travis,<br>&gt; <br>&gt; That's the same problem like in Windows. Copy mkbundle.exe I sent you<br>&gt; in the folder with the assemblies you want to bundle and call it
 like<br>&gt; this:<br>&gt; <br>&gt; mono mkbundle.exe ...<br>&gt; <br>&gt; Robert<br>&gt; <br>&gt; Travis Staloch wrote:<br>&gt;&gt; Hey Robert,<br>&gt;&gt; <br>&gt;&gt; I've been trying to use mkbundle now on my linux FC5 box and seem<br>&gt;&gt; to be getting an error with it.  The app itself runs fine on linux<br>&gt;&gt; after making some changes to the dllmap entries in <br>&gt;&gt; /usr/local/etc/mono/config.   However when I use try to run the <br>&gt;&gt; mkbundle command below, I get the error listed below.  (The error <br>&gt;&gt; says that it can't seem to find my InstallerCommon.dll which is in <br>&gt;&gt; the same directory  as MyInstaller.exe).<br>&gt;&gt; <br>&gt;&gt; Thanks for any advice.<br>&gt;&gt; <br>&gt;&gt; --Travis<br>&gt;&gt; <br>&gt;&gt; <br>&gt;&gt;&gt; mono /usr/local/lib/mono/1.0/mkbundle.exe -z --deps --config-dir<br>&gt;&gt;&gt; . MyInstaller.exe<br>&gt;&gt; (BTW, I've tried leaving off the '--config-dir .' switch too).<br>&gt;&gt;
 <br>&gt;&gt; Unhandled Exception: System.IO.FileNotFoundException: <br>&gt;&gt; InstallerCommon, Version=1.0.2336.677, Culture=neutral : <br>&gt;&gt; InstallerCommon, Version=1.0.2336.677, Culture=neutral at &lt;0x00000&gt;<br>&gt;&gt;  at (wrapper managed-to-native) System.AppDomain:LoadAssembly <br>&gt;&gt; (string,System.Security.Policy.Evidence,bool) at <br>&gt;&gt; System.AppDomain.Load (System.Reflection.AssemblyName assemblyRef, <br>&gt;&gt; System.Security.Policy.Evidence assemblySecurity) [0x00000] at <br>&gt;&gt; (wrapper remoting-invoke-with-check) System.AppDomain:Load <br>&gt;&gt;  (System.Reflection.AssemblyName,System.Security.Policy.Evidence) at<br>&gt;&gt;  System.AppDomain.Load (System.Reflection.AssemblyName assemblyRef)<br>&gt;&gt;  [0x00000] at (wrapper remoting-invoke-with-check) <br>&gt;&gt; System.AppDomain:Load (System.Reflection.AssemblyName) at <br>&gt;&gt; System.Reflection.Assembly.Load (System.Reflection.AssemblyName <br>&gt;&gt; assemblyRef)
 [0x00000] at MakeBundle.QueueAssembly <br>&gt;&gt; (System.Collections.ArrayList files, System.String codebase) <br>&gt;&gt; [0x00000] at MakeBundle.Main (System.String[] args) [0x00000]<br>&gt;&gt; <br>&gt;&gt; <br>&gt;&gt; Robert Jordan  wrote: Hi,<br>&gt;&gt; <br>&gt;&gt; If you bundle you app on a Linux 2.4 system, the binary should work<br>&gt;&gt;  an all systems.<br>&gt;&gt; <br>&gt;&gt; The problem on Linux are the native dependencies (GLib, GTK) that<br>&gt;&gt; you have to deliver. I can't help you with that, because I never<br>&gt;&gt; did it myself.<br>&gt;&gt; <br>&gt;&gt; You may  try to put them in the private "lib" dir of your<br>&gt;&gt; application and change LD_LIBRARY_PATH from inside of a launcher<br>&gt;&gt; script to point to this lib dir.<br>&gt;&gt; <br>&gt;&gt; Robert<br>&gt;&gt; <br>&gt;&gt; --------------------------------- Get your own web address for just<br>&gt;&gt;  $1.99/1st yr. We'll help. Yahoo! Small Business.<br>&gt; <br>&gt; <br>&gt;
 <br>&gt;  --------------------------------- Talk is cheap. Use Yahoo!<br>&gt; Messenger to make PC-to-Phone calls.  Great rates starting at 1�/min.<br></robertj@gmx.net></blockquote><br><div>    </div><hr size="1">Do you Yahoo!?<br>  Get on board. <a href="http://us.rd.yahoo.com/evt=40791/*http://advision.webevents.yahoo.com/mailbeta">You're invited</a> to try the new Yahoo! Mail.</blockquote><br><p>&#32;
                <hr size=1><a href="http://us.rd.yahoo.com/evt=43256/*http://advision.webevents.yahoo.com/mailbeta"> All-new Yahoo! Mail </a>- Fire up a more powerful email and get things done faster.