<html xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns="http://www.w3.org/TR/REC-html40">

<head>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">
<meta name=ProgId content=Word.Document>
<meta name=Generator content="Microsoft Word 11">
<meta name=Originator content="Microsoft Word 11">
<link rel=File-List href="cid:filelist.xml@01C6F436.1440CC00">
<!--[if gte mso 9]><xml>
 <o:OfficeDocumentSettings>
  <o:DoNotRelyOnCSS/>
 </o:OfficeDocumentSettings>
</xml><![endif]--><!--[if gte mso 9]><xml>
 <w:WordDocument>
  <w:SpellingState>Clean</w:SpellingState>
  <w:GrammarState>Clean</w:GrammarState>
  <w:DocumentKind>DocumentEmail</w:DocumentKind>
  <w:EnvelopeVis/>
  <w:ValidateAgainstSchemas/>
  <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid>
  <w:IgnoreMixedContent>false</w:IgnoreMixedContent>
  <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText>
  <w:Compatibility>
   <w:BreakWrappedTables/>
   <w:SnapToGridInCell/>
   <w:WrapTextWithPunct/>
   <w:UseAsianBreakRules/>
   <w:UseWord2002TableStyleRules/>
  </w:Compatibility>
  <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel>
 </w:WordDocument>
</xml><![endif]--><!--[if gte mso 9]><xml>
 <w:LatentStyles DefLockedState="false" LatentStyleCount="156">
 </w:LatentStyles>
</xml><![endif]-->
<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:"Trebuchet MS";
        panose-1:2 11 6 3 2 2 2 2 2 4;
        mso-font-charset:0;
        mso-generic-font-family:swiss;
        mso-font-pitch:variable;
        mso-font-signature:647 0 0 0 159 0;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {mso-style-parent:"";
        margin:0cm;
        margin-bottom:.0001pt;
        mso-pagination:widow-orphan;
        font-size:12.0pt;
        font-family:"Times New Roman";
        mso-fareast-font-family:"Times New Roman";}
a:link, span.MsoHyperlink
        {color:blue;
        text-decoration:underline;
        text-underline:single;}
a:visited, span.MsoHyperlinkFollowed
        {color:purple;
        text-decoration:underline;
        text-underline:single;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        mso-style-noshow:yes;
        mso-ansi-font-size:10.0pt;
        mso-bidi-font-size:10.0pt;
        font-family:"Trebuchet MS";
        mso-ascii-font-family:"Trebuchet MS";
        mso-hansi-font-family:"Trebuchet MS";
        color:navy;
        font-weight:normal;
        font-style:normal;
        text-decoration:none;
        text-underline:none;
        text-decoration:none;
        text-line-through:none;}
span.SpellE
        {mso-style-name:"";
        mso-spl-e:yes;}
span.GramE
        {mso-style-name:"";
        mso-gram-e:yes;}
@page Section1
        {size:612.0pt 792.0pt;
        margin:72.0pt 90.0pt 72.0pt 90.0pt;
        mso-header-margin:35.4pt;
        mso-footer-margin:35.4pt;
        mso-paper-source:0;}
div.Section1
        {page:Section1;}
-->
</style>
<!--[if gte mso 10]>
<style>
 /* Style Definitions */ 
 table.MsoNormalTable
        {mso-style-name:"Table Normal";
        mso-tstyle-rowband-size:0;
        mso-tstyle-colband-size:0;
        mso-style-noshow:yes;
        mso-style-parent:"";
        mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
        mso-para-margin:0cm;
        mso-para-margin-bottom:.0001pt;
        mso-pagination:widow-orphan;
        font-size:10.0pt;
        font-family:"Times New Roman";
        mso-ansi-language:#0400;
        mso-fareast-language:#0400;
        mso-bidi-language:#0400;}
</style>
<![endif]-->
</head>

<body lang=EN-US link=blue vlink=purple style='tab-interval:36.0pt'>

<div class=Section1>

<p class=MsoNormal><font size=2 color=navy face="Trebuchet MS"><span
style='font-size:10.0pt;font-family:"Trebuchet MS";color:navy'>I was wondering
has anyone else has experienced this:<o:p></o:p></span></font></p>

<p class=MsoNormal><font size=2 color=navy face="Trebuchet MS"><span
style='font-size:10.0pt;font-family:"Trebuchet MS";color:navy'><o:p>&nbsp;</o:p></span></font></p>

<p class=MsoNormal><font size=2 face="Courier New"><span style='font-size:10.0pt;
font-family:"Courier New"'>Unhandled Exception: <span class=SpellE>MySql.Data.MySqlClient.MySqlException</span>:
There is already an open <span class=SpellE>DataReader</span> associated with
this Connection which must be closed first.<o:p></o:p></span></font></p>

<p class=MsoNormal><font size=2 face="Courier New"><span style='font-size:10.0pt;
font-family:"Courier New"'><span style='mso-spacerun:yes'>&nbsp; </span><span
class=GramE>at</span> <span class=SpellE>MySql.Data.MySqlClient.MySqlCommand.CheckState</span>
() [0x00000] <o:p></o:p></span></font></p>

<p class=MsoNormal><font size=2 face="Courier New"><span style='font-size:10.0pt;
font-family:"Courier New"'><span style='mso-spacerun:yes'>&nbsp; </span><span
class=GramE>at</span> <span class=SpellE>MySql.Data.MySqlClient.MySqlCommand.ExecuteReader</span>
(<span class=SpellE>CommandBehavior</span> behavior) [0x00000] <o:p></o:p></span></font></p>

<p class=MsoNormal><font size=2 face="Courier New"><span style='font-size:10.0pt;
font-family:"Courier New"'><span style='mso-spacerun:yes'>&nbsp; </span><span
class=GramE>at</span> <span class=SpellE>MySql.Data.MySqlClient.MySqlCommand.ExecuteReader</span>
() [0x00000] <o:p></o:p></span></font></p>

<p class=MsoNormal><font size=2 face="Courier New"><span style='font-size:10.0pt;
font-family:"Courier New"'><span style='mso-spacerun:yes'>&nbsp; </span><span
class=GramE>at</span> (wrapper <span class=SpellE>remoting</span>-invoke-with-check)
<span class=SpellE>MySql.Data.MySqlClient.MySqlCommand:ExecuteReader</span> ()<o:p></o:p></span></font></p>

<p class=MsoNormal><font size=2 face="Courier New"><span style='font-size:10.0pt;
font-family:"Courier New"'><span style='mso-spacerun:yes'>&nbsp; </span><span
class=GramE>at</span> <span class=SpellE>MySql.Data.MySqlClient.Driver.ReportWarnings</span>
() [0x00000]<o:p></o:p></span></font></p>

<p class=MsoNormal><font size=2 face="Courier New"><span style='font-size:10.0pt;
font-family:"Courier New"'><o:p>&nbsp;</o:p></span></font></p>

<p class=MsoNormal><font size=2 color="#333399" face="Trebuchet MS"><span
style='font-size:10.0pt;font-family:"Trebuchet MS";mso-bidi-font-family:"Courier New";
color:#333399'>I receive this error when trying to execute a stored procedure
(other SQL statements work fine, even other stored procedures). It works fine
on windows with .NET but on mono (windows or <span class=SpellE>linux</span>) I
receive that error.<o:p></o:p></span></font></p>

<p class=MsoNormal><font size=2 color="#333399" face="Trebuchet MS"><span
style='font-size:10.0pt;font-family:"Trebuchet MS";mso-bidi-font-family:"Courier New";
color:#333399'><o:p>&nbsp;</o:p></span></font></p>

<p class=MsoNormal><font size=2 color="#333399" face="Trebuchet MS"><span
style='font-size:10.0pt;font-family:"Trebuchet MS";mso-bidi-font-family:"Courier New";
color:#333399'>If anyone has any help or tips that would be much appreciated.<o:p></o:p></span></font></p>

<p class=MsoNormal><font size=2 color="#333399" face="Trebuchet MS"><span
style='font-size:10.0pt;font-family:"Trebuchet MS";mso-bidi-font-family:"Courier New";
color:#333399'><o:p>&nbsp;</o:p></span></font></p>

<p class=MsoNormal><font size=2 color="#333399" face="Trebuchet MS"><span
style='font-size:10.0pt;font-family:"Trebuchet MS";mso-bidi-font-family:"Courier New";
color:#333399'>Cheers in advance.<o:p></o:p></span></font></p>

</div>

</body>

</html>