<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=us-ascii">
<META content="MSHTML 6.00.6000.16441" name=GENERATOR></HEAD>
<BODY>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2>Hi,</FONT></SPAN></DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial size=2>I have the following 
section inside my app.config file :</FONT></SPAN></DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV><FONT face=Arial size=2>&nbsp; 
&lt;runtime&gt;<BR>&nbsp;&nbsp;&nbsp; &lt;assemblyBinding 
xmlns="urn:schemas-microsoft-com:asm.v1"&gt;<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 
&lt;probing privatePath="<SPAN 
class=492265414-06062007>myPath</SPAN>"/&gt;<BR>&nbsp;&nbsp;&nbsp; 
&lt;/assemblyBinding&gt;<BR>&nbsp; &lt;/runtime&gt;</FONT>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial size=2>This is supposed to 
be the equivalent of&nbsp;doing this at the beginning of the application 
:</FONT></SPAN></DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2>AppDomain.CurrentDomain.AppendPrivatePath("myPath");</FONT></SPAN></DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial size=2>Since the 
AppendPrivatePath method is deprecated, I want to use the app.config way, but it 
doesn't work on Mono.&nbsp; Therefore, I have to stick with the deprecated 
method for now.</FONT></SPAN></DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial size=2>I searched the bug 
database and found out that there was already a&nbsp;bug logged about this issue 
(57612), but the status of this bug hasn't changed since 2005-07-06 and it seems 
to have been forgotten.&nbsp; Somebody submitted a patch but I still have the 
bug with the latest version.</FONT></SPAN></DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial size=2>Has the patch been 
merged into the main version?</FONT></SPAN></DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2></FONT></SPAN>&nbsp;</DIV>
<DIV><SPAN class=492265414-06062007><FONT face=Arial 
size=2>Jonathan</FONT></SPAN></DIV></BODY></HTML>