Hello,<br><br>There is a problem setting different MonoDocumentRootDir for different virtual hosts (same ip but different ports). <br><br>The following settings work fine for the html pages<br>I have test.html at both locations (/srv/www/htdocs/test and /srv/www/htdocs/testjs). When I use 
<a href="http://localhost:80/test.html">http://localhost:80/test.html</a> it displays the content of test.html placed at /srv/www/htdocs/test location and with <a href="http://localhost:81">http://localhost:81</a> /test.html it displays the content of 
test.html placed at /srv/www/htdocs/testjs location<br><br>But when I try to access .aspx it always point to /srv/www/htdocs/test&quot; with both the ports 80,81.<br><br>When I add MonoDocumentRootDir &quot;/srv/www/htdocs/test&quot;&nbsp; and MonoDocumentRootDir &quot;/srv/www/htdocs/testjs&quot; in their respective virtualroot it gives &quot;File not found: 
test.aspx&quot;<br><br><br>&lt;VirtualHost 192.168.X.X:80&gt;<br>&nbsp;&nbsp; DocumentRoot /srv/www/htdocs/test<br>&nbsp;&nbsp; ServerName bit-dl-slmono<br>&nbsp;&nbsp; ServerPath /test/<br>&nbsp;&nbsp; LoadModule mono_module /usr/lib/apache2/mod_mono.so<br>&nbsp;&nbsp; MonoServerPath default /usr/bin/mod-mono-server2
<br>&nbsp;&nbsp; AddMonoApplications default &quot;/:/srv/www/htdocs/test&quot;<br>&nbsp;&nbsp; &lt;Directory &quot;/srv/www/htdocs/test&quot;&gt;<br>&nbsp;&nbsp; &nbsp;Order allow,deny<br>&nbsp;&nbsp; &nbsp;Allow from all<br>&nbsp;&nbsp; &nbsp;SetHandler mono<br>&nbsp;&nbsp; &nbsp;&lt;IfModule mod_dir.c&gt;
<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;Directoryindex index.aspx<br>&nbsp;&nbsp; &nbsp;&lt;/IfModule&gt;<br>&nbsp;&nbsp; &lt;/Directory&gt;<br>&lt;/VirtualHost&gt;<br><br>&lt;VirtualHost 192.168.X.X:81&gt;<br>&nbsp;&nbsp; DocumentRoot /srv/www/htdocs/testjs<br>&nbsp;&nbsp; ServerName bit-dl-slmono
<br>&nbsp;&nbsp; ServerPath /testjs/<br>&nbsp;&nbsp; LoadModule mono_module /usr/lib/apache2/mod_mono.so<br>&nbsp;&nbsp; MonoServerPath default /usr/bin/mod-mono-server2<br>&nbsp;&nbsp; AddMonoApplications default &quot;/:/srv/www/htdocs/testjs&quot;<br>&nbsp;&nbsp; &lt;Directory &quot;/srv/www/htdocs/testjs&quot;&gt;
<br>&nbsp;&nbsp; &nbsp;Order allow,deny<br>&nbsp;&nbsp; &nbsp;Allow from all<br>&nbsp;&nbsp; &nbsp;SetHandler mono<br>&nbsp;&nbsp; &nbsp;&lt;IfModule mod_dir.c&gt;<br>&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;Directoryindex index.aspx<br>&nbsp;&nbsp; &nbsp;&lt;/IfModule&gt;<br>&nbsp;&nbsp; &lt;/Directory&gt;<br>&lt;/VirtualHost&gt;<br><br>
Please help me to resolve this problem.<br><br>Thanks,<br>Jyoti Seth<br>