It works fine in Mono on windows, so I would look at your Linux distribution<br><br>C:\Documents and Settings\huskeyw\My Documents\SharpDevelop Projects\charTest\bi<br>n\Debug&gt;mono charTest.exe<br>ao<br>teste 
<br><br><br>my code<br>using System;<br>using System.Collections.Generic;<br><br>namespace charTest<br>{<br>&nbsp;&nbsp;&nbsp; class MainClass<br>&nbsp;&nbsp;&nbsp; {<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; public static void Main(string[] args)<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; {<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; System.Threading.Thread.CurrentThread.CurrentCulture
 = new System.Globalization.CultureInfo(&quot;pt-BR&quot;); <br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Console.WriteLine(&quot;&quot;);<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; <br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Console.WriteLine(&quot;teste &quot;); <br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; Console.ReadKey
();<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; }<br>&nbsp;&nbsp;&nbsp; }<br>}<br><br><br>my mono version<br><br>n\Debug&gt;mono --version<br>Mono JIT compiler version 1.2.4 (tarball)<br>Copyright (C) 2002-2007 Novell, Inc and Contributors. <a href="http://www.mono-project.com">
www.mono-project.com</a><br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; TLS:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; normal<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; GC:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Included Boehm (with typed GC)<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; SIGSEGV:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; normal<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Architecture:&nbsp; x86<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Disabled:&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; none<br><br><br><br>
<div><span class="gmail_quote">On 6/22/07, <b class="gmail_sendername">Ivan de Queiroz</b> &lt;<a href="mailto:iqueiroz.go@gmail.com">iqueiroz.go@gmail.com</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Hi! <br> <p>I am writing a console application, but, i having a problem with <br> encoding. If i write a message with non-us characters (), i get <br> &#39;????&#39; <br> </p><p>I change the current cultureinfo, but, no success... 
<br> </p><p>my code: <br> </p><p>using System; <br> </p><p>namespace teste <br> { <br> &nbsp; &nbsp; public class teste <br> &nbsp; &nbsp; { <br> &nbsp; &nbsp; &nbsp; &nbsp; public static void Main(string[] args) <br> &nbsp; &nbsp; &nbsp; &nbsp; { <br> &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; System.Threading.Thread.CurrentThread.CurrentCulture

 = new <br> System.Globalization.CultureInfo(&quot;pt-BR&quot;); <br> &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; Console.WriteLine(&quot;teste &quot;); <br> &nbsp; &nbsp; &nbsp; &nbsp; } <br> &nbsp; &nbsp; } <br> </p><div style="display: block;">} 
<br> <br>Note: i am using remoting in my project.... the object is serialized, and international characteres are replaced to &#39;???&#39;... its a bug in mono or in my brain?<br><br></div>Thanks for any help <br><span class="sg">
<br clear="all">
<br>-- <br>Ivan<br>:wq!
</span><br>_______________________________________________<br>Mono-list maillist &nbsp;- &nbsp;<a onclick="return top.js.OpenExtLink(window,event,this)" href="mailto:Mono-list@lists.ximian.com">Mono-list@lists.ximian.com</a><br><a onclick="return top.js.OpenExtLink(window,event,this)" href="http://lists.ximian.com/mailman/listinfo/mono-list" target="_blank">
http://lists.ximian.com/mailman/listinfo/mono-list</a><br><br></blockquote></div><br><br clear="all"><br>-- <br>William S. Huskey<br><br>UNIX Systems Engineer<br><br>Maritime Systems Solutions Division<br><br>SAIC<br><br>
Tel: 425-267-5643<br><br>Email: <a href="mailto:huskeyw@saic.com">huskeyw@saic.com</a>