<div>When I add LoadModule directive to httpd.conf and configure my VirtualHost :</div>
<div>&nbsp;</div>
<div>
<p>&lt;VirtualHost <a href="http://204.15.10.40">204.15.10.40</a>&gt;<br>ServerAlias <a href="http://www.bhph.com/">www.bhph.com</a><br>ServerAdmin <a href="mailto:webmaster@bhph.com">webmaster@bhph.com</a><br>DocumentRoot /home/bhph/public_html
<br>User bhph<br>Group bhph<br>ServerName <a href="http://bhph.com">bhph.com</a></p>
<p>LoadModule mono_module /usr/lib64/httpd/modules/libmod_mono.so<br>MonoServerPath default /usr/bin/mod-mono-server2<br>AddMonoApplications default &quot;/:/home/bhph/public_html&quot;<br>&lt;Directory &quot;/home/bhph/public_html&quot;&gt;
<br>&nbsp;&nbsp;&nbsp; Other allow, deny<br>&nbsp;&nbsp;&nbsp; Allow from all<br>&nbsp;&nbsp;&nbsp; SetHandler mono<br>&nbsp;&nbsp;&nbsp; &lt;ifModule mod_dir.c&gt;<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; DirectoryIndex index.aspx<br>&nbsp;&nbsp;&nbsp; &lt;/ifModule&nbsp; &gt;<br>&lt;/Directory&gt;</p>
<p>User bhph<br>Group bhph<br>BytesLog /usr/local/apache/domlogs/bhph.com-bytes_log<br>CustomLog /usr/local/apache/domlogs/bhph.com combined<br>ScriptAlias /cgi-bin/ /home/bhph/public_html/cgi-bin/<br>&lt;/VirtualHost&gt;
</p>
<p>&lt;Location &quot;/home/bhph/public_html&quot;&gt;<br>&nbsp;&nbsp;&nbsp; AddHandler mono .aspx .ascx .asax .ashx .config .cs .asmx<br>&lt;/Location&gt;<br></p></div>
<div>&nbsp;</div>
<div>I have next error with starting apache server :</div>
<div>&nbsp;</div>
<div>[root@H101 init.d]# httpd start<br>Syntax error on line 212 of /usr/local/apache/conf/httpd.conf:<br>Cannot load /usr/lib64/httpd/modules/libmod_mono.so into server: /usr/lib64/httpd/modules/libmod_mono.so: undefined symbol: ap_hook_post_config
<br>/usr/sbin/httpd start: httpd could not be started<br>&nbsp;</div>
<div>Please help me.<br><br>&nbsp;</div><br>