<a href="http://lists.ximian.com/pipermail/mono-list/2007-October/036777.html"></a><pre>Hi guys,<br>Actually, I have the same problem. What is the suggestion about of this?<br>change the call to <i><i><i><i>get_HashAlgorithmType </i></i></i></i>in provider of mysql or wait for the implementation of <br>
<i><i>System.Web.Security.Membership.get_HashAlgorithmType </i></i>?<br><br>Best Regards,<br>Rolando.<br><br><br>I didn&#39;t compile anything, I&#39;m just starting xsp2 from the command line...<br><br><br><br>On 10/30/07, Vasili Sviridov &lt;<a href="http://lists.ximian.com/mailman/listinfo/mono-list">vsviridov at exceede.com</a>&gt; wrote:<br>
&gt;<i><br></i>&gt;<i> According to reflector there&#39;s only 1 place in MySql.Web.dll where that<br></i>&gt;<i> method (get_HashAlgorithmType) is called.<br></i>&gt;<i> And if password format is set to encrypted - it should never get there.<br>
</i>&gt;<i> I&#39;m not sure you can fix it otherwise.<br></i>&gt;<i><br></i>&gt;<i> Btw, is this a compile-time error or runtime error?<br></i>&gt;<i><br></i>&gt;<i> V.<br></i>&gt;<i><br></i>&gt;<i> J.S. Martin wrote:<br>
</i>&gt;<i> &gt; I changed that information, but it still throws the error...<br></i>&gt;<i> &gt;<br></i>&gt;<i> &gt;<br></i>&gt;<i> &gt;<br></i>&gt;<i> &gt; On 10/30/07, *Vasili Sviridov* &lt;<a href="http://lists.ximian.com/mailman/listinfo/mono-list">vsviridov at exceede.com</a><br>
</i>&gt;<i> &gt; &lt;mailto:<a href="http://lists.ximian.com/mailman/listinfo/mono-list">vsviridov at exceede.com</a>&gt;&gt; wrote:<br></i>&gt;<i> &gt;<br></i>&gt;<i> &gt;     Yes<br></i>&gt;<i> &gt;<br></i>&gt;<i> &gt;     V.<br>
</i>&gt;<i> &gt;<br></i>&gt;<i> &gt;<br></i>&gt;<i> &gt;     J.S. Martin wrote:<br></i>&gt;<i> &gt;&gt;     Do you mean like setting the passwordFormat to &quot;Encrypted&quot;<br></i>&gt;<i> &gt;&gt;     instead of &quot;Hashed&quot;?<br>
</i>&gt;<i> &gt;&gt;<br></i>&gt;<i> &gt;&gt;     On 10/30/07, *Vasili Sviridov* &lt; <a href="http://lists.ximian.com/mailman/listinfo/mono-list">vsviridov at exceede.com</a><br></i>&gt;<i> &gt;&gt;     &lt;mailto:<a href="http://lists.ximian.com/mailman/listinfo/mono-list">vsviridov at exceede.com</a>&gt;&gt; wrote:<br>
</i>&gt;<i> &gt;&gt;<br></i>&gt;<i> &gt;&gt;         If you can override the membership setting to have the password<br></i>&gt;<i> &gt;&gt;         Encrypted and not hashed - it should bypass that exception.<br></i>&gt;<i> &gt;&gt;<br>
</i>&gt;<i> &gt;&gt;         J.S. Martin wrote:<br></i>&gt;<i> &gt;&gt;         &gt; Well, it throws this error when I try to create a user with<br></i>&gt;<i> &gt;&gt;         a &quot;just<br></i>&gt;<i> &gt;&gt;         &gt; plain&quot; normal create user wizard.<br>
</i>&gt;<i> &gt;&gt;         &gt;<br></i>&gt;<i> &gt;&gt;         &gt;<br></i>&gt;<i> &gt;&gt;         &gt;<br></i>&gt;<i> &gt;&gt;         &gt;<br></i>&gt;<i> &gt;&gt;         &gt; On 10/30/07, *Vasili Sviridov* &lt;<a href="http://lists.ximian.com/mailman/listinfo/mono-list">vsviridov at exceede.com</a><br>
</i>&gt;<i> &gt;&gt;         &lt;mailto:<a href="http://lists.ximian.com/mailman/listinfo/mono-list">vsviridov at exceede.com</a>&gt;<br></i>&gt;<i> &gt;&gt;         &gt; &lt;mailto:<a href="http://lists.ximian.com/mailman/listinfo/mono-list">vsviridov at exceede.com</a><br>
</i>&gt;<i> &gt;&gt;         &lt;mailto:<a href="http://lists.ximian.com/mailman/listinfo/mono-list">vsviridov at exceede.com</a>&gt;&gt;&gt; wrote:<br></i>&gt;<i> &gt;&gt;         &gt;<br></i>&gt;<i> &gt;&gt;         &gt;     J.S. Martin wrote:<br>
</i>&gt;<i> &gt;&gt;         &gt;<br></i>&gt;<i> &gt;&gt;         &gt;     What membership method are you using when it throws this<br></i>&gt;<i> &gt;&gt;         exception?<br></i>&gt;<i> &gt;&gt;         &gt;<br></i>&gt;<i> &gt;&gt;         &gt;     That method is still not implemented in mono, but that<br>
</i>&gt;<i> &gt;&gt;         could be<br></i>&gt;<i> &gt;&gt;         &gt;     bypassed.<br></i>&gt;<i> &gt;&gt;         &gt;<br></i>&gt;<i> &gt;&gt;         &gt;     V.<br></i>&gt;<i> &gt;&gt;         &gt;     &gt; I&#39;ve switched over to the MySQL Connector/Net<br>
</i>&gt;<i> membership<br></i>&gt;<i> &gt;&gt;         &gt;     provider - it<br></i>&gt;<i> &gt;&gt;         &gt;     &gt; works on .NET, but on Mono I&#39;m getting this error...<br></i>&gt;<i> &gt;&gt;         &gt;     &gt;<br>
</i>&gt;<i> &gt;&gt;         &gt;     &gt;<br></i>&gt;<i> &gt;&gt;         &gt;     &gt;     //Method not found:<br></i>&gt;<i> &gt;&gt;         &gt;     &gt;<br></i>&gt;<i> &gt;&gt;         &#39;System.Web.Security.Membership.get_HashAlgorithmType &#39;./<br>
</i>&gt;<i> &gt;&gt;<br></i>&gt;<i> &gt;<br></i>&gt;<i> &gt;<br></i>&gt;<i> &gt;<br></i>&gt;<i> &gt; --<br></i>&gt;<i> &gt; _________________________________<br></i>&gt;<i> &gt;<br></i>&gt;<i> &gt; Joshua S. Martin<br></i>&gt;<i><br>
</i>&gt;</pre>