<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">You seem to have installed a bunch of weird dependencies into your environment. &nbsp;I suggest following the wiki with a clean environment.<div><br></div><div>iconv is included with osx, eglib is the only support glib method on x86_64 darwin, etc.</div><div><br></div><div>-g</div><div><br><div><div>On 2010-07-21, at 2:06 PM, Sylvain Pointeau wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite">I re-installed libiconv on /usr/local/<br><br>and I run the command:<br><br>CPPFLAGS="-I/usr/local/include" LDFLAGS="-L/usr/local/lib" ./autogen.sh --prefix=/user/local/mono270/ --host=x86_64-apple-darwin10<br>
<br>I had a message saying I should not use host but build? do you have an idea?<br>what are the value I can put? same as host?<br><br>but I made "make", seems to run now.<br><br>is it correct?<br><br>Best regards,<br>
Sylvain<br><br><div class="gmail_quote">On Wed, Jul 21, 2010 at 6:45 PM, Geoff Norton <span dir="ltr">&lt;<a href="mailto:gnorton@novell.com">gnorton@novell.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<div style="word-wrap: break-word;">You dont; only eglib is supported on x86-64; libiconv is shipped with apples compiler tho; so you'll need to figure out whats wrong with your environment.<div><br></div><font color="#888888"><div>
-g</div></font><div><div></div><div class="h5"><div><br><div><div>On 2010-07-21, at 12:41 PM, Sylvain Pointeau wrote:</div><br><blockquote type="cite">I just made<br><br>&gt; svn co <a href="http://anonsvn.mono-project.com/source/trunk/mono" target="_blank">http://anonsvn.mono-project.com/source/trunk/mono</a><br>
&gt; ./autogen.sh --prefix=/user/local/mono270/ --host=x86_64-apple-darwin10<br>
&gt; make<br><br>I have:<br><br>Undefined symbols:<br>&nbsp; "_libiconv_open", referenced from:<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; _monoeg_g_convert in libeglib.a(libeglib_la-gunicode.o)<br>&nbsp; "_libiconv_close", referenced from:<br>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; _monoeg_g_convert in libeglib.a(libeglib_la-gunicode.o)<br>
&nbsp; "_libiconv", referenced from:<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; _monoeg_g_convert in libeglib.a(libeglib_la-gunicode.o)<br>ld: symbol(s) not found<br><br><br>How to force it by taking the glib2 in my /usr/local/ ?<br><br>Many thanks for your help,<br>

Sylvain<br>
</blockquote></div><br></div></div></div></div></blockquote></div><br>
</blockquote></div><br></div></body></html>