<HTML><BODY style="word-wrap: break-word; -khtml-nbsp-mode: space; -khtml-line-break: after-white-space; "><DIV><BR class="khtml-block-placeholder"></DIV>If you are running on an active directory account what is your gid and uid - the result of ( as you prob. know) typing id in the terminal?<DIV><BR class="khtml-block-placeholder"></DIV><DIV>-- Eoin</DIV><DIV><BR><DIV><DIV>On 4 Apr 2007, at 15:57, Daniel Abrams wrote:</DIV><BR class="Apple-interchange-newline"><BLOCKQUOTE type="cite"><BR><BR><DIV><SPAN class="gmail_quote">On 4/4/07, <B class="gmail_sendername">Eoin Norris</B> &lt;<A href="mailto:e.norris@mac.com">e.norris@mac.com</A>&gt; wrote:</SPAN><BLOCKQUOTE class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"> <BR><BR>Well, my application is generally home-based but I would kinda think<BR>15% of all users high, though it may be 15% of all macs deployed<BR>across  "schools, colleges, companies, government" but whatever about <BR>schools macs in the enterprise are extremely rare. So the total of<BR>all macs is lower.</BLOCKQUOTE><DIV><BR><BR>Perhaps.  I worked for Apple in what was the Enterprise and Education divisions, and I think my numbers are pretty conservative, but maybe the ratio has shrunk.  I can tell you that one of my current clients is a large government agency, and macs are not as rare as you might think, and they all use active directory authentication. <BR></DIV><BR><BLOCKQUOTE class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><BR><BR>It is an issue for deployment as well. I am getting reports in the<BR> field. I dont know specifically where to look in the Mono code<BR>( where it is happening) but the thread below ( taken from this list)<BR>gives some examples. The original poster does not seem to be on the<BR>list anymore, or not contributing to this new thread on the same <BR>issue, but might be available on that email address.<BR><BR><A href="http://lists.ximian.com/pipermail/mono-osx/2006-January/000444.html">http://lists.ximian.com/pipermail/mono-osx/2006-January/000444.html</A><BR><BR> <BR>He clearly did some research and ascertained that it was an Apple bug.</BLOCKQUOTE><DIV><BR>I can't say if its an Apple bug or not.  I could certainly believe that POSIX threads are done differently in Mac OS X than in Linux, and that the Apple implementation is incomplete or buggy, I don't have much experience in that area.  But I do know that in higher level environments, Java, ObjC, etc, thread and process management work fine on OS X and that many other development and deployment environments have managed to solve threading issues without dying early on Mac OS X.  Unless it's solved, it effectively rules out Mono development for us, but I understand that your mileage may vary. <BR></DIV><BR></DIV><BR></BLOCKQUOTE></DIV><BR></DIV></BODY></HTML>