<html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Greetings. I'm wondering if anyone can provide insight into installing mono, xsp, and mod_mono on a Santa Rosa MacBook running Leopard (detailed system specs below). &nbsp;I've run the packaged installer, and everything seems to go okay, but I have since discovered that even simple tests of the framework fail. &nbsp;I can start xsp and mod-mono-server, and they report that they are listening on appropriate addresses and ports, but they fail to respond when queried. &nbsp;And mod_mono won't even install at all. &nbsp;The make install simply places a symlink (mod_mono.so) to a non-existent file (mod_mono.0.0.0.so) in the Apache modules folder<br><br>I read in other forums that modules such as mod_jk have issues with Leopard and/or the Santa Rosa architecture because they still try to install for i386 when Santa Rosa requires x86-64. &nbsp;So after several frustrating days, I went through the makefile for mod_mono and tried to change i386 references to x86-64, but I don't really have a lot of experience doing that, and it did nothing for me.<br><br>Detailed system specifications:<br>Hardware: MacBook,3,1<br>CPU: Intel Core 2 Duo 2.2GHz (Santa Rosa)<br>RAM: 2GB<br>OS: Mac OS X 10.5.1<br>X11: &nbsp;2.1.0 - X.org X11R7.2<br>mono: 1.2.5.2<br>xsp: 1.1.16.1 (I've tried 1.2.6, too)<br>mod_mono:1.2.6<br><br>If you need more information, just let me know! &nbsp;And thanks in advance for any and all assistance!<br><br>Rev. Jeremy R. Geerdes, Pastor<br>Debra Heights Wesleyan Church<br>4025 Lower Beaver Rd.<br>Des Moines, IA 50310<br><br>p/f: (515) 279-5212<br>h: (515) 277-7491<br><a href="mailto:jgeerdes@mchsi.com">jgeerdes@mchsi.com</a><br><br><br><br></body></html>