Hi everyone, I&#39;m new to the list (but not to Mono) and wanted to say hello :)&nbsp;<div><br class="webkit-block-placeholder"></div><div>I&#39;m using the System.IO.Compression.DeflateStream to handle some streams. &nbsp;This&nbsp;apparently&nbsp;depends on Mono.Posix.Dll which internally calls a &quot;DllImport&quot; on &quot;MonoPosixHelper.&quot; &nbsp;The executable that I&#39;m using has been bundled with Mono Linker / mkbundle2.exe with the --deps option. &nbsp;Everything is working great, EXCEPT for functions&nbsp;requiring&nbsp;MonoPosixHelper. &nbsp;The following exception is raised:</div>
<div><br class="webkit-block-placeholder"></div><div><div>System.DllNotFoundException: /Library/Frameworks/Mono.framework/Versions/1.2.6/lib/libMonoPosixHelper.dylib</div><div>&nbsp;&nbsp;at (wrapper managed-to-native) System.IO.Compression.DeflateStream:create_z_stream (System.IO.Compression.CompressionMode,bool)</div>
<div>&nbsp;&nbsp;at System.IO.Compression.DeflateStream..ctor (System.IO.Stream compressedStream, CompressionMode mode, Boolean leaveOpen, Boolean gzip) [0x00000]&nbsp;</div><div>&nbsp;&nbsp;at System.IO.Compression.DeflateStream..ctor (System.IO.Stream compressedStream, CompressionMode mode, Boolean leaveOpen) [0x00000]&nbsp;</div>
<div>&nbsp;&nbsp;at (wrapper remoting-invoke-with-check) System.IO.Compression.DeflateStream:.ctor (System.IO.Stream,System.IO.Compression.CompressionMode,bool)</div><div><br class="webkit-block-placeholder"></div><div><br class="webkit-block-placeholder">
</div><div>The file definitely exists at&nbsp;/Library/Frameworks/Mono.framework/Versions/1.2.6/lib/libMonoPosixHelper.dylib</div><div><br class="webkit-block-placeholder"></div><div>This location has been referenced through a DllMap entry in the following .config file:</div>
<div><br class="webkit-block-placeholder"></div><div><div>&lt;configuration&gt;</div><div>&nbsp;&nbsp; &nbsp; &nbsp; &nbsp;&lt;dllmap dll=&quot;MonoPosixHelper&quot; target=&quot;/Library/Frameworks/Mono.framework/Versions/1.2.6/lib/libMonoPosixHelper.dylib&quot; /&gt;</div>
<div>&lt;/configuration&gt;</div><div><br class="webkit-block-placeholder"></div><div>Has anyone experienced an issue like this before?</div><div><br class="webkit-block-placeholder"></div></div></div>