<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
<META NAME="Generator" CONTENT="MS Exchange Server version 6.5.7652.24">
<TITLE>Can't compile any VB.NET code</TITLE>
</HEAD>
<BODY>
<!-- Converted from text/plain format -->

<P><FONT SIZE=2>Even the dummy code from the simple VB console app won't compile:<BR>
<BR>
Public Class application<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Public Shared Sub Main()<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; System.Console.WriteLine(&quot;Hello world!&quot;)<BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; End Sub<BR>
End Class<BR>
<BR>
See complete build output below.<BR>
<BR>
I found a similar error report elsewhere:<BR>
<BR>
<A HREF="http://lists.ximian.com/pipermail/mono-vb/2008-February.txt">http://lists.ximian.com/pipermail/mono-vb/2008-February.txt</A><BR>
<BR>
But I couldn't find any resolution of that reported problem.<BR>
<BR>
I can compile CS console apps, just not VB.NET apps.<BR>
<BR>
Any idea what's wrong with Mono?<BR>
<BR>
PowerPC, OS X 10.4.11, Mono 1.2.6_6 - installed without any problems.<BR>
<BR>
Thanks.<BR>
<BR>
-Phil<BR>
<BR>
<BR>
<BR>
Building Project: vbconsole_test (Debug)<BR>
Performing main compilation...<BR>
vbnc -out:&quot;/Users/philhess/Development/Mono/vbconsole_test/bin/Debug/vbconsole_test.exe&quot; -nologo -utf8output -target:exe&nbsp; &quot;/Users/philhess/Development/Mono/vbconsole_test/application.vb&quot;<BR>
<BR>
** (/Library/Frameworks/Mono.framework/Versions/1.2.6/lib/mono/2.0/vbnc.exe:878): WARNING **: The class Mono.WebBrowser.DOM.IDocument could not be loaded, used in Mono.Mozilla, Version=0.2.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756<BR>
<BR>
** (/Library/Frameworks/Mono.framework/Versions/1.2.6/lib/mono/2.0/vbnc.exe:878): WARNING **: The class Mono.WebBrowser.DOM.IElement could not be loaded, used in Mono.Mozilla, Version=0.2.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756<BR>
<BR>
** (/Library/Frameworks/Mono.framework/Versions/1.2.6/lib/mono/2.0/vbnc.exe:878): WARNING **: The class Mono.WebBrowser.DOM.IWindow could not be loaded, used in Mono.Mozilla, Version=0.2.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756<BR>
Error : VBNC99999: Unexpected error: The classes in the module cannot be loaded.<BR>
&nbsp; at &lt;0x00000&gt; &lt;unknown method&gt;<BR>
&nbsp; at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)<BR>
&nbsp; at System.Reflection.Assembly.GetTypes () [0x00000] in /private/tmp/monobuild/build/BUILD/mono-1.2.6/mcs/class/corlib/System.Reflection/Assembly.cs:326<BR>
&nbsp; at vbnc.TypeManager.LoadReferencedTypes () [0x00000]<BR>
&nbsp; at vbnc.TypeManager.LoadReferenced () [0x00000]<BR>
&nbsp; at vbnc.Compiler.Compile () [0x00000]<BR>
Compilation took 00:00:04.6190320<BR>
<BR>
Build complete -- 0 errors, 0 warnings<BR>
</FONT>
</P>

</BODY>
</HTML>