<html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Hello,<div><br></div><div>so it seems I'm not alone with this.</div><div>I tried to switch off the addins but I couldn't figure out which ones are right.</div><div>I switched off the Linux deployment support but nothing changed.</div><div>Reproducig the "freezing" of the application was not possible. &nbsp;But I'm not sure whether the installation process worked properly. The were no error messages.&nbsp;</div><div>But the icon of Mono develop does not appear in the program folder of finder. Or should it be like this?&nbsp;</div><div>And &nbsp;syntax highlighting + underlining of errors is definitely not working.</div><div>What am I doing wrong?&nbsp;<br><div><br>Anfang der weitergeleiteten E-Mail:<br class="Apple-interchange-newline"><blockquote type="cite"><div><div style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; "><font face="Helvetica" size="3" color="#000000" style="font: 12.0px Helvetica; color: #000000"><b>Von: </b></font><font face="Helvetica" size="3" style="font: 12.0px Helvetica">Norbert Pausch &lt;<a href="mailto:napau@t-online.de">napau@t-online.de</a>></font></div><div style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; "><font face="Helvetica" size="3" color="#000000" style="font: 12.0px Helvetica; color: #000000"><b>Datum: </b></font><font face="Helvetica" size="3" style="font: 12.0px Helvetica">20. März 2008 20:44:24 MEZ</font></div><div style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; "><font face="Helvetica" size="3" color="#000000" style="font: 12.0px Helvetica; color: #000000"><b>An: </b></font><font face="Helvetica" size="3" style="font: 12.0px Helvetica">Geoff Norton &lt;<a href="mailto:gnorton@novell.com">gnorton@novell.com</a>></font></div><div style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; "><font face="Helvetica" size="3" color="#000000" style="font: 12.0px Helvetica; color: #000000"><b>Betreff: </b></font><font face="Helvetica" size="3" style="font: 12.0px Helvetica"><b>Re: [Mono-osx] Mono Develop</b></font></div><div style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; min-height: 14px; "><br></div> </div>Just to make the information complete: the messages from starting up the IDE<br><br>Last login: Thu Mar 20 20:23:44 on ttys000<br>/Library/Frameworks/Mono.framework/Versions/1.9/bin/monodevelop ; exit;<br>Macintosh:~ np$ /Library/Frameworks/Mono.framework/Versions/1.9/bin/monodevelop ; exit;<br>WARNING: Cannot find Mozilla directory containing libgtkembedmoz.so. Some Addins may not be able to function. Please set MOZILLA_FIVE_HOME to your Mozilla directory.<br>Thu Mar 20 20:30:11 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br>Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value "((GString*) 0x16e3f6c0)" of type `GString'<br>Thu Mar 20 20:30:11 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br>Thu Mar 20 20:30:11 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br>Thu Mar 20 20:30:11 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br><br>Test.vb created with Thu Mar 20 20:34:07 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br>Thu Mar 20 20:34:07 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br>Thu Mar 20 20:34:28 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br>Thu Mar 20 20:34:28 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br>Thu Mar 20 20:34:29 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br>Thu Mar 20 20:34:29 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br>ERROR [2008-03-20 20:34:41Z]: GLib.GException: Format der Bilddatei unbekannt<br> &nbsp;at Gdk.PixbufLoader.Write (System.Byte[] buf, UInt64 count) [0x00000]<br> &nbsp;at Gdk.PixbufLoader.Write (System.Byte[] bytes, UInt32 count) [0x00000]<br> &nbsp;at Gdk.PixbufLoader.LoadFromStream (System.IO.Stream input) [0x00000]<br> &nbsp;at Gdk.PixbufLoader.InitFromStream (System.IO.Stream stream) [0x00000]<br> &nbsp;at Gdk.PixbufLoader..ctor (System.IO.Stream stream) [0x00000]<br> &nbsp;at Gdk.Pixbuf..ctor (System.IO.Stream stream) [0x00000]<br> &nbsp;at MonoDevelop.Core.Gui.ResourceService.InternalGetStockIdFromResource (Mono.Addins.RuntimeAddin addin, System.String id) [0x00000]<br> &nbsp;at MonoDevelop.Core.Gui.ResourceService.PrivGetStockId (Mono.Addins.RuntimeAddin addin, System.String filename) [0x00000]<br> &nbsp;at MonoDevelop.Core.Gui.ResourceService.InternalGetStockId (Mono.Addins.RuntimeAddin addin, System.String filename) [0x00000]<br> &nbsp;at MonoDevelop.Core.Gui.ResourceService.GetStockId (Mono.Addins.RuntimeAddin addin, System.String filename) [0x00000]<br> &nbsp;at MonoDevelop.Projects.Gui.IconService.InitializeIcons (System.String path) [0x00000]<br> &nbsp;at MonoDevelop.Projects.Gui.IconService.InitializeService () [0x00000]<br> &nbsp;at MonoDevelop.Core.ServiceManager.FetchService (System.Type serviceType) [0x00000]<br> &nbsp;at MonoDevelop.Core.ServiceManager.GetService (System.Type serviceType) [0x00000]<br> &nbsp;at MonoDevelop.Ide.Services.get_Icons () [0x00000]<br> &nbsp;at MonoDevelop.Ide.Gui.Pads.ProjectPad.ProjectNodeBuilder.BuildNode (ITreeBuilder treeBuilder, System.Object dataObject, System.String&amp; label, Gdk.Pixbuf&amp; icon, Gdk.Pixbuf&amp; closedIcon) [0x00000]<br> &nbsp;at MonoDevelop.Ide.Gui.Pads.TreeViewPad+TreeBuilder.UpdateNode (MonoDevelop.Ide.Gui.Pads.NodeBuilder[] chain, NodeAttributes ats, System.Object dataObject) [0x00000]<br><br>and starting to edit the source<br>(MonoDevelop:256): Pango-WARNING **: couldn't load font "fixed 12", falling back to "Sans 12", expect ugly output.<br>Thu Mar 20 20:34:42 Macintosh.local monodevelop[256] &lt;Error>: CGBitmapContextGetBitsPerPixel: invalid context<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>ERROR [2008-03-20 20:38:42Z]: Could not start monodoc : {0}<br>System.ComponentModel.Win32Exception: ApplicationName='monodoc', CommandLine='--help', CurrentDirectory=''<br> &nbsp;at System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000]<br> &nbsp;at System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000]<br> &nbsp;at System.Diagnostics.Process.Start () [0x00000]<br> &nbsp;at MonoDevelop.Core.Execution.ProcessWrapper.Start () [0x00000]<br> &nbsp;at (wrapper remoting-invoke-with-check) MonoDevelop.Core.Execution.ProcessWrapper:Start ()<br> &nbsp;at MonoDevelop.Core.Execution.ProcessService.StartProcess (System.Diagnostics.ProcessStartInfo startInfo, MonoDevelop.Core.Execution.ProcessEventHandler outputStreamChanged, MonoDevelop.Core.Execution.ProcessEventHandler errorStreamChanged, System.EventHandler exited) [0x00000]<br> &nbsp;at MonoDevelop.Core.Execution.ProcessService.StartProcess (System.String command, System.String arguments, System.String workingDirectory, MonoDevelop.Core.Execution.ProcessEventHandler outputStreamChanged, MonoDevelop.Core.Execution.ProcessEventHandler errorStreamChanged, System.EventHandler exited, Boolean redirectStandardInput) [0x00000]<br> &nbsp;at MonoDevelop.Core.Execution.ProcessService.StartProcess (System.String command, System.String arguments, System.String workingDirectory, System.IO.TextWriter outWriter, System.IO.TextWriter errorWriter, System.EventHandler exited, Boolean redirectStandardInput) [0x00000]<br> &nbsp;at MonoDevelop.Ide.Gui.HelpOperations.CheckExternalMonodoc () [0x00000]<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br>gtk_menu_item_paint: scaling = 0,800000 &nbsp;&nbsp;size = 14 &nbsp;&nbsp;extent = 11<br><br><br>In the following at least line 19 should produce an error and as far as I understood be underlined: ' User: np at 21:48 29.02.2008<br>'<br>' To change standard headers go to Edit->Preferences->Coding->Standard Headers<br>'<br><br>Option Explicit On<br>Option Strict On<br><br>Imports System<br>Imports NUnit.Framework<br><br><br>Namespace DirAnalyse<br><span class="Apple-tab-span" style="white-space:pre">        </span><br><span class="Apple-tab-span" style="white-space:pre">        </span>&lt;TestFixture()> &nbsp;_<br><span class="Apple-tab-span" style="white-space:pre">        </span>Public Class Test<br><span class="Apple-tab-span" style="white-space:pre">        </span>Private Ivar Integer<br><span class="Apple-tab-span" style="white-space:pre">        </span>Xrivate Wert Decimal<br><span class="Apple-tab-span" style="white-space:pre">        </span><br><span class="Apple-tab-span" style="white-space:pre">        </span><br><span class="Apple-tab-span" style="white-space:pre">        </span><span class="Apple-tab-span" style="white-space:pre">        </span>&lt;Test()> &nbsp;_<br><span class="Apple-tab-span" style="white-space:pre">        </span><span class="Apple-tab-span" style="white-space:pre">        </span>Public Sub TestCase()<br><span class="Apple-tab-span" style="white-space:pre">        </span><span class="Apple-tab-span" style="white-space:pre">        </span>End Sub<br><span class="Apple-tab-span" style="white-space:pre">        </span>End Class<br>End Namespace<br>I<br>Showing the freezed boxes ist not easy<br><br>Am 20.03.2008 um 19:28 schrieb Geoff Norton:<br><br><blockquote type="cite"><br></blockquote><blockquote type="cite">On 20-Mar-08, at 1:41 PM, Norbert Pausch wrote:<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite"><blockquote type="cite">Installing Mono 1.9 on MAC OS Leopard (Mac Mini) was succesful. I<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">tried out Mono develop but I'm not sure what it should look like.<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">The icons do not appear in the program folder. Mono develop can be<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">started via command line. The system however does not find the library<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">"libgtkembedmoz.so". The variable MOZILLA_FIVE_HOME is required to be<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">set to the appropriate path. However the library cannot be found on my<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">system by spotlight.<br></blockquote></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">This isn't needed on the mac. &nbsp;Its a warning not an error.<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite"><blockquote type="cite"><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">The IDE comes up, but several things seem to be strange:<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">-Syntax highlighting is not working<br></blockquote></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">Syntax highlighting works fine here, please file a bug with a reproducable test case.<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite"><blockquote type="cite"><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">-Some boxes for error messages "freeze" and the system can not be<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite">stopped normally.<br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><br></blockquote></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">I dont see this either, please file a bug with a reproducable test case.<br></blockquote><blockquote type="cite"><br></blockquote><blockquote type="cite">-g<br></blockquote><blockquote type="cite"><br></blockquote><br></blockquote></div><br></div></body></html>