Nothing happens when I&nbsp;&nbsp;run &#39;mono MonoDevelop.exe&#39;&nbsp;. &nbsp;I have tried various recommendations from the different emails. &nbsp;None have worked. &nbsp;I have wiped my System and re-installed my OS, so it couldn&#39;t have to do with previous versions of Mono.<div>
<br></div><div>Running 10.4.11 PPC.</div><div><br></div><div>When I ran with mono --debug, I got.</div><div><span class="Apple-style-span" style="font-weight: bold;"><br></span></div><div><div><span class="Apple-style-span" style="font-weight: bold;">** (/Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin/MonoDevelop.exe:2527): WARNING **: Symbol file /Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin/MonoDevelop.exe.mdb has incorrect version (expected 50.0, got 39)</span></div>
<div><span class="Apple-style-span" style="font-weight: bold;"><br></span></div><div><span class="Apple-style-span" style="font-weight: bold;">** (/Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin/MonoDevelop.exe:2527): WARNING **: Symbol file /Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin/MonoDevelop.Ide.dll.mdb has incorrect version (expected 50.0, got 39)</span></div>
<div><span class="Apple-style-span" style="font-weight: bold;"><br></span></div><div><span class="Apple-style-span" style="font-weight: bold;">** (/Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin/MonoDevelop.exe:2527): WARNING **: Symbol file /Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin/MonoDevelop.Core.dll.mdb has incorrect version (expected 50.0, got 39)</span></div>
<div><span class="Apple-style-span" style="font-weight: bold;"><br></span></div><div><span class="Apple-style-span" style="font-weight: bold;">** (/Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin/MonoDevelop.exe:2527): WARNING **: Symbol file /Library/Frameworks/Mono.framework/Versions/2.0.1/lib/mono/gac/Mono.Addins.Setup/0.3.0.0__0738eb9f132ed756/Mono.Addins.Setup.dll.mdb has incorrect version (expected 50.0, got 39)</span></div>
<div><span class="Apple-style-span" style="font-weight: bold;"><br></span></div><div><span class="Apple-style-span" style="font-weight: bold;">** (/Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin/MonoDevelop.exe:2527): WARNING **: Symbol file /Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin/MonoDevelop.Core.Gui.dll.mdb has incorrect version (expected 50.0, got 39)</span></div>
<div><span class="Apple-style-span" style="font-weight: bold;"><br></span></div><div><span class="Apple-style-span" style="font-weight: bold;">** (/Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin/MonoDevelop.exe:2527): WARNING **: Symbol file /Library/Frameworks/Mono.framework/Versions/2.0.1/lib/mono/gac/Mono.Addins/0.3.0.0__0738eb9f132ed756/Mono.Addins.dll.mdb has incorrect version (expected 50.0, got 39)</span></div>
<div><br></div><div><br></div><div>After deleting those .mdb files and rerunning. &nbsp;I got</div><div><br></div><div><div><span class="Apple-style-span" style="font-weight: bold;">Assembly not found: gtksourceview2-sharp, Version=<a href="http://2.0.0.0">2.0.0.0</a>, Culture=neutral, PublicKeyToken=35e10195dab3c99f</span></div>
<div><span class="Apple-style-span" style="font-weight: bold;">WARNING: Could not scan file: /Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/AddIns/MonoDevelop.SourceEditor.dll</span></div></div><div><br></div>
</div><div><br></div><div><br></div><div><br></div><div><br></div><div>Kevin</div><div><br></div><div><br><br><div class="gmail_quote">On Mon, Oct 27, 2008 at 4:26 PM, Marc Christensen <span dir="ltr">&lt;<a href="mailto:mchristensen@novell.com">mchristensen@novell.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">Kevin Heeney wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="Ih2E3d">
The new MonoDevelop does not work for me either. <br>
I have Mono 2.0.1 that was released the other day.<br>
Mac OS X Tiger 10.4.11 PPC<br>
<br></div>
On Mon, Oct 27, 2008 at 3:51 PM, Marc Christensen &lt;<a href="mailto:mchristensen@novell.com" target="_blank">mchristensen@novell.com</a> &lt;mailto:<a href="mailto:mchristensen@novell.com" target="_blank">mchristensen@novell.com</a>&gt;&gt; wrote:<br>

</blockquote>
[snip]<div class="Ih2E3d"><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
 &nbsp; &nbsp;Hey Norbert, can you open a shell and CD into<br>
<br>
 &nbsp; &nbsp;/Applications/Monodevelop.app/Contents/MacOS/lib/monodevelop/bin<br>
<br>
 &nbsp; &nbsp;and run &#39;mono MonoDevelop.exe&#39; for me? &nbsp;What version of macosx are you<br>
 &nbsp; &nbsp;running? &nbsp;What version of Mono do you have installed?<br>
<br>
 &nbsp; &nbsp;We tested on Macosx 10.5.4 with mono-2.0 and everything works fine.<br>
<br>
 &nbsp; &nbsp;Thanks!<br>
</blockquote>
<br>
<br></div>
Hey Kevin, thanks for the report! &nbsp;What I&#39;m interested in knowing is if it&#39;s the actual binaries that are not working or if it&#39;s related to the monovevelop shell script that gets executed when you click on the icon that&#39;s broken.<br>

<br>
Also, I&#39;m interested in knowing if this problem only exists on macosx 10.4.x.<br>
<br>
So, some questions:<br>
<br>
1) Is anyone seeing this on 10.5.x machines?<br>
<br>
2) Can people on 10.4.x/10.5.x run the binary directly using mono from the command line as outlined above?<br>
<br>
3) On what versions of macosx (version and arch) are we seeing the issue?<br>
<br>
4) On what version of mono are we seeing the issue?<br>
<br>
Thanks again to everyone for helping us track this down. &nbsp;You all are awesome!<div><div></div><div class="Wj3C7c"><br>
<br>
--<br>
Marc Christensen<br>
<a href="http://www.novell.com" target="_blank">http://www.novell.com</a><br>
</div></div></blockquote></div><br></div>