This still doesn&#39;t work for me :( Clicking on the icon fails to launch it, and I get this in the console:<br><br>===== Thursday, 30 October 2008 20:36:23 Europe/London =====<br>RegisterProcess failed (error = -50)<br>Stacktrace:<br>
<br>&nbsp; at (wrapper managed-to-native) Gtk.Application.gtk_init (int&amp;,intptr&amp;) &lt;0x00004&gt;<br>&nbsp; at (wrapper managed-to-native) Gtk.Application.gtk_init (int&amp;,intptr&amp;) &lt;0xffffffff&gt;<br>&nbsp; at Gtk.Application.Init () &lt;0x0003b&gt;<br>
&nbsp; at MonoDevelop.Ide.Gui.IdeStartup.Run (string[]) &lt;0x000f0&gt;<br>&nbsp; at MonoDevelop.Startup.SharpDevelopMain.Main (string[]) &lt;0x00077&gt;<br>&nbsp; at (wrapper runtime-invoke) MonoDevelop.Startup.SharpDevelopMain.runtime_invoke_int_string[] (object,intptr,intptr,intptr) &lt;0xffffffff&gt;<br>
<br>I get the exact same if I run the script in a terminal from my home directory (Bitmap:~ jools$ /Applications/MonoDevelop.app/Contents/MacOS/monodevelop). <br><br>If I find MonoDevelop.exe and run that directly the GUI comes up, but with a bunch of errors on the console + error popups. I tried creating a new C# project, but that threw an exception:<br>
<br>Bitmap:/Applications/MonoDevelop.app/Contents/MacOS/lib/monodevelop/bin jools$ mono MonoDevelop.exe<br>ERROR [2008-10-30 20:46:30Z]: Could not load Apache mime database<br>System.IO.DirectoryNotFoundException: Could not find a part of the path &quot;/etc/apache2/mime.types&quot;.<br>
&nbsp; at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) [0x00000] <br>&nbsp; at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share) [0x00000] <br>
&nbsp; at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare)<br>&nbsp; at System.IO.File.OpenRead (System.String path) [0x00000] <br>&nbsp; at MonoDevelop.Platform.MacPlatform.LoadMimeMap () [0x00000] <br>
ERROR [2008-10-30 20:46:30Z]: Add-in error (MonoDevelop.CBinding,1.9.0): Add-in could not be loaded: The required addin &#39;MonoDevelop.Deployment,1.9.0&#39; is not installed.<br>Mono.Addins.MissingDependencyException: The required addin &#39;MonoDevelop.Deployment,1.9.0&#39; is not installed.<br>
&nbsp; at Mono.Addins.AddinSessionService.ResolveLoadDependencies (System.Collections.ArrayList addins, System.Collections.Stack depCheck, System.String id, Boolean optional) [0x00000] <br>&nbsp; at Mono.Addins.AddinSessionService.ResolveLoadDependencies (System.Collections.ArrayList addins, System.Collections.Stack depCheck, System.String id, Boolean optional) [0x00000]&nbsp; <br>
(more stuff like this: are you interested in it ?)<br><br>I&#39;m running OSX 10.4.11 on an Intel iMac. X11 (and all the developer tools) are installed.<br><br>Let me know if any other information would be helpful.<br><br>
Julian<br><br><div class="gmail_quote">2008/10/29 Rusty Howell <span dir="ltr">&lt;<a href="mailto:rhowell@novell.com">rhowell@novell.com</a>&gt;</span><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">




<div bgcolor="#ffffff" text="#000000">
Hey folks,<br>
We have a new <a href="ftp://ftp.novell.com/pub/mono/archive/2.0.1/macos-10-universal/1/MonoDevelop-1.9-3.dmg" target="_blank">MonoDevelop-1.9-3.dmg</a>
for you all to test. We&#39;ve been having some issues with it, so we hope
some things will be fixed.<br>
If you come across any bugs, please reply to this thread with your
issue. <br>
<br>
Also, feel free to check <a href="http://mono-project.com/Bugs" target="_blank">Bugzilla</a>
for your bug.<br>
Review the <a href="https://bugzilla.novell.com/buglist.cgi?query_format=advanced&amp;short_desc_type=allwordssubstr&amp;short_desc=&amp;long_desc_type=fulltext&amp;long_desc=&amp;classification=Mono&amp;product=MonoDevelop&amp;bug_file_loc_type=allwordssubstr&amp;bug_file_loc=&amp;status_whiteboard_type=allwordssubstr&amp;status_whiteboard=&amp;keywords_type=anywords&amp;keywords=&amp;deadlinefrom=&amp;deadlineto=&amp;bug_status=NEW&amp;bug_status=ASSIGNED&amp;bug_status=NEEDINFO&amp;bug_status=REOPENED&amp;bug_severity=Blocker&amp;bug_severity=Critical&amp;bug_severity=Major&amp;bug_severity=Normal&amp;bug_severity=Minor&amp;bug_severity=Enhancement&amp;op_sys=Mac&amp;op_sys=Mac+System+7&amp;op_sys=Mac+System+7.5&amp;op_sys=Mac+System+7.6.1&amp;op_sys=Mac+System+8.0&amp;op_sys=Mac+System+8.5&amp;op_sys=Mac+System+8.6&amp;op_sys=Mac+System+9.x&amp;op_sys=Mac+OS+X+10.0&amp;op_sys=Mac+OS+X+10.1&amp;op_sys=Mac+OS+X+10.2&amp;op_sys=Mac+OS+X+10.3&amp;op_sys=Mac+OS+X+10.4&amp;op_sys=Mac+OS+X+1%0A0.5&amp;emailassigned_to1=1&amp;emailtype1=substring&amp;email1=&amp;emailassigned_to2=1&amp;emailreporter2=1&amp;emailqa_contact2=1&amp;emailcc2=1&amp;emailtype2=substring&amp;email2=&amp;bugidtype=include&amp;bug_id=&amp;votes=&amp;chfieldfrom=&amp;chfieldto=Now&amp;chfieldvalue=&amp;cmdtype=doit&amp;order=Reuse+same+sort+as+last+time&amp;field0-0-0=noop&amp;type0-0-0=noop&amp;value0-0-0=" target="_blank">list
of open bugs</a> before logging a new one. Feel free to add
info/comments to an existing bug, <br>
(like your system info) so we can tack down issues.<br>
<br>
And please <a href="https://bugzilla.novell.com/enter_bug.cgi?alias=&amp;assigned_to=&amp;blocked=&amp;bug_file_loc=http%3A%2F%2F&amp;bug_severity=Normal&amp;bug_status=NEW&amp;cf_biz_priority=&amp;cf_foundby=---&amp;cf_nts_priority=&amp;cf_nts_support_num=&amp;cf_partnerid=&amp;comment=Please%20describe%20your%20environment%3A%0D%0AHardware%20architecture%3A%0D%0AOS%20version%3A%0D%0AMono%20version%3A%0D%0AXcode%20version%20%28if%20installed%29%3A%0D%0A%0D%0ASteps%20to%20reproduce%20the%20problem%3A%0D%0A%0D%0A%0D%0AExpected%20results%3A%0D%0A%0D%0A%0D%0AActual%20results%3A%0D%0A%0D%0A%0D%0AHow%20often%20does%20this%20happen%3F%0D%0A&amp;component=&amp;contenttypeentry=&amp;contenttypemethod=autodetect&amp;contenttypeselection=text%2Fplain&amp;data=&amp;deadline=&amp;dependson=&amp;description=&amp;estimated_time=0.0&amp;flag_type-2=X&amp;flag_type-3=X&amp;form_name=enter_bug&amp;keywords=&amp;maketemplate=Remember%20values%20as%20bookmarkable%20template&amp;op_sys=Other&amp;priority=P5%%0A20-%20None&amp;product=MonoDevelop&amp;qa_contact=&amp;rep_platform=Other&amp;short_desc=&amp;version=1.9" target="_blank">log
new bugs</a> with as much detailed information as possible.<br>
<br>
Thanks<br>
<br>
Rusty Howell<br>
</div>

<br>_______________________________________________<br>
Mono-osx mailing list<br>
<a href="mailto:Mono-osx@lists.ximian.com">Mono-osx@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-osx" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-osx</a><br>
<br></blockquote></div><br>