<br><br><div class="gmail_quote">On Fri, Dec 11, 2009 at 1:35 PM, ptr <span dir="ltr">&lt;<a href="mailto:ptrajkumar@gmail.com">ptrajkumar@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<br><br><div class="gmail_quote"><div><div></div><div class="h5">On Fri, Dec 11, 2009 at 1:13 PM, Andrew Jorgensen <span dir="ltr">&lt;<a href="mailto:ajorgensen@novell.com" target="_blank">ajorgensen@novell.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Oh, the URL for CSDK should be the same as the links on that download<br>
page but with -CSDK right after MonoFramework.  That page is generated<br>
by a very old script that I keep forgetting to update.<br>
<br>
It is very strange that NAnt needs to find mono.pc in order to feel like<br>
it can do something.  We may decide to put that file in the main package<br>
so that NAnt works.  Would you mind filing a bug to that effect and<br>
assigning it to me?<br>
<br>
Thanks,<br>
<font color="#888888">Andrew<br>
</font><div><div></div><div><br>
On Fri, 2009-12-11 at 07:55 -0500, Duane Wandless wrote:<br>
&gt; Fantastic.  Is the install available for the CSDK?  Or can steps be<br>
&gt; provided to install the headers?<br>
&gt;<br>
&gt;<br>
&gt; I have an OSX embedded application so I need the headers so I can<br>
&gt; compile the mono domain load code.<br>
&gt;<br>
&gt;<br>
&gt; I also assume this is why NAnt did not work:<br>
&gt; NAnt 0.86 (Build 0.86.2898.0; beta1; 12/8/2007)<br>
&gt; Copyright (C) 2001-2007 Gerry Shaw<br>
&gt; <a href="http://nant.sourceforge.net" target="_blank">http://nant.sourceforge.net</a><br>
&gt;<br>
&gt;<br>
&gt; BUILD FAILED<br>
&gt;<br>
&gt;<br>
&gt; Failed to initialize the &#39;Mono 3.5 Profile&#39; (mono-3.5) target<br>
&gt; framework.<br>
&gt;<br>
&gt;<br>
&gt;     Unable to locate &#39;mono&#39; module using pkg-config. Download the Mono<br>
&gt; development packages from <a href="http://www.mono-project.com/downloads/" target="_blank">http://www.mono-project.com/downloads/</a>.<br>
&gt;<br>
&gt;<br>
&gt; For more information regarding the cause of the build failure, run the<br>
&gt; build again in debug mode.<br>
&gt;<br>
&gt;<br>
&gt; # pkg-config --modversion mono<br>
&gt; Package glib-2.0 was not found in the pkg-config search path.<br>
&gt; Perhaps you should add the directory containing `glib-2.0.pc&#39;<br>
&gt;<br>
&gt;<br>
&gt; I look forward to testing with this release.<br>
&gt; Thanks,<br>
&gt; Duane<br>
&gt;<br>
&gt;<br>
&gt; On Thu, Dec 10, 2009 at 8:18 PM, Andrew Jorgensen<br>
&gt; &lt;<a href="mailto:ajorgensen@novell.com" target="_blank">ajorgensen@novell.com</a>&gt; wrote:<br>
&gt;         Hey Everyone,<br>
&gt;<br>
&gt;         We released Mono 2.6 RC1! This is an amazing release with a<br>
&gt;         long list of<br>
&gt;         improvements.  Draft release notes are here:<br>
&gt;         <a href="http://www.go-mono.com/archive/2.6" target="_blank">http://www.go-mono.com/archive/2.6</a><br>
&gt;<br>
&gt;         As always, you can get the preview/RC releases here:<br>
&gt;         <a href="http://mono.ximian.com/monobuild/preview/download-preview/" target="_blank">http://mono.ximian.com/monobuild/preview/download-preview/</a><br>
&gt;<br>
&gt;         Report any bugs that you may find using our Bugs page, AND<br>
&gt;         reply to this<br>
&gt;         thread with the bug numbers so we can track them:<br>
&gt;         <a href="http://www.mono-project.com/Bugs" target="_blank">http://www.mono-project.com/Bugs</a><br>
&gt;<br>
&gt;         Special attention is given to regressions, so if you can tell<br>
&gt;         us a<br>
&gt;         version of Mono where the bug worked and you add [Regression]<br>
&gt;         to the<br>
&gt;         beginning of the summary of the bug, then it is much more<br>
&gt;         likely your<br>
&gt;         bug will get fixed.<br>
&gt;<br>
&gt;         Please help us make 2.6 the best mono yet.<br>
&gt;<br>
&gt;         Thanks!<br>
&gt;<br>
&gt;         Mono QA<br>
&gt;<br>
&gt;<br>
&gt;         _______________________________________________<br>
&gt;         Mono-osx mailing list<br>
&gt;         <a href="mailto:Mono-osx@lists.ximian.com" target="_blank">Mono-osx@lists.ximian.com</a><br>
&gt;         <a href="http://lists.ximian.com/mailman/listinfo/mono-osx" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-osx</a><br>
&gt;<br>
&gt;<br>
<br></div></div></blockquote><div><br></div></div></div><div>I have filed a bug 564116 against this issue.</div><div class="im"><div> </div></div></div></blockquote><div><br></div><div>Also copying glib-2.0.pc and gthread*.pc to the same directory seems to fix the issue</div>
<div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="gmail_quote"><div class="im"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div>
<div>
<br>
_______________________________________________<br>
Mono-osx mailing list<br>
<a href="mailto:Mono-osx@lists.ximian.com" target="_blank">Mono-osx@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-osx" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-osx</a><br>
</div></div></blockquote></div></div><br>
</blockquote></div><br>