I'd like to suggest keeping to the naming convention of the obj-c 
classes.  For example the MonoMac binding for NSArray.objectAtIndex has 
been changed to ValueAt.  The main reason not to change the names is for
 documentation.  I can look up what NSArray objectAtIndex does on the 
web very easily.  But I have to perform a translation of ValueAt to get 
to objectAtIndex.  Yes this example is trivial but the argument holds up
 as more of the core libraries are bound.<br>
<br>
I want my obj-c counterparts to be able to read the C# MonoMac code with
 as much ease as possible.  If selectors have subtle name changes the 
maintainability of the code is actually reduced.  The obj-c coder knows what to do with objectAtIndex but must &#39;learn&#39; what ValueAt does.  Yes again this is a trivial example but the concept is valid.<br><br>Ideally I could take obj-c code and do a line by line translation.  There may be better ways to write the code in C# MonoMac but the rewrite should not require function name changes.<br>
<br>Thanks<br>Duane (trustme)<br>
<br>Another example is: NSURLConnection.  This was changed to NSUrlConnection.<br>