I modified the mono backtrace macro to be this:<div><div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace">define monobacktrace</font></div><div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace"> select-frame 0</font></div>
<div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace"> set $i = 0</font></div><div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace"> while ($i &lt; $arg0)</font></div><div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace">   <b>set $foo = (char*)mono_pmip ($pc)</b></font></div>
<div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace">  <b> if ($foo)</b></font></div><div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace"><b>     printf &quot;#%d %p in %s\n&quot;, $i, $pc, $foo</b></font></div>
<div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace"><b>   else</b></font></div><div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace"><b>     frame</b></font></div><div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace"><b>   end</b></font></div>
<div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace">   up-silently</font></div><div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace">   set $i = $i + 1</font></div><div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace"> end</font></div>
<div><font class="Apple-style-span" face="&#39;courier new&#39;, monospace">end</font></div><div><br></div><div>The change is to cast the result of mono_pmip to (char*) and to check if ($foo) rather than if ($foo == 0x00).</div>
<div><div><br></div><div>Duane<br>



<br><div class="gmail_quote">On Tue, Aug 3, 2010 at 9:06 AM, Duane Wandless <span dir="ltr">&lt;<a href="mailto:duane@wandless.net">duane@wandless.net</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
I had been using mono_backtrace as described here, <a href="http://www.mono-project.com/Debugging" target="_blank">http://www.mono-project.com/Debugging</a>.<div><br></div><div>When I use 2.6.7 with MonoMac I receive this error:</div>
<div>
Invalid type combination in equality test.</div><div><br></div><div>My guess is mono_pmip is not working as expected.</div><div><br></div><div>If there is a simple answer, let me know.  I use this a lot in debugging my embedded app.</div>

<div><br></div><div>Thanks,</div><div>Duane</div>
</blockquote></div><br></div></div></div>