Miguel,<div><br></div><div>Glad the patches were satisfactory, I look forward to contributing more.<div><br><div>As requested, I changed the capitalization but did not drop &quot;Component&quot; in the member names.  I will submit shortly, but wanted to resolve one other naming issue first.</div>
<meta charset="utf-8"><div><br></div><div>There are currently 30 ObjC methods named &quot;numberOfXxx&quot; in appkit.cs, and 1 in coreimage.cs and there does not seem to be a standard for the C# name.  I have seen</div><div>
<br></div><div>  NumberOfXxx</div><div>  Xxx</div><div>  CountOfXxx</div><div>  XxxCount</div><div>  Count</div><div><br></div><div>Leaving it NumberOfXxx, doesn&#39;t seem very C#ish, and Count is only appropriate if the object is clearly a collection.  Dropping the NumberOf is usually confusing, for example shortening the NSColor method numberOfComponents to just Components is mis-leading because it does not return the components (which is an array of floats).  Granted intellisense helps, but I think a good standard name helps make the code more readable.  So, what should it be?</div>
<div><br></div><div>My vote is Count or XxxCount, depending on the object.</div><div><br></div><div><br></div><div><div class="gmail_quote">On Fri, Dec 31, 2010 at 4:45 AM, Miguel de Icaza <span dir="ltr">&lt;<a href="mailto:miguel@novell.com">miguel@novell.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">Hello Regan,<div><div class="gmail_quote"><div class="im"><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Attached is a git-diff output file for corrections to the NSColor interface in appkit.cs<div>
Also attached is NSColor.cs which provides strongly typed bindings for the two obj-c methods that take *CGFloat input.</div><div>
(I did not include the diff to the Makefile)</div></blockquote><div><br></div></div><div>Thanks for the fixes, I liked them very much.   I am not sure how we even got those NSColor bindings there, I could have sworn I had reviewed every API that we checked in to remove bad names (although I still find some every once in a while).</div>
<div class="im">
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><br></div><div>I added out parameters in the interface where appropriate, and the generator created correct code in all case.  Of course this relies on continuing correct behavior of the generator, but in my opinion is much cleaner than creating additional wrapper methods to deal with an IntPtr.</div>

</blockquote></div><div><br>Agreed.</div><div class="im"><div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div>I did a minimal amount of method/parameter renaming to be internally consist (as I saw it).</div>

</blockquote><div><br></div></div><div>I liked them.   And these are important for two reasons: they show up on intellisense, and can provide valuable information to the developer while he is developing, without having to look up the documentation, and because with C# 4.0 users will be able to name their parameters.   So good parameter names are important.</div>
<div class="im">
<div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div>I resisted the urge to do more extensive renaming, because I wasn&#39;t sure it was appropriate.  I would like to rename XxxxxRGBA() to XxxxxRgba() for consistency with MonoMac.CoreImage.CIColor and System.Drawing.Color. I also considered dropping &quot;Component&quot; from xxxComponent. (i.e RedComponent { get;} would become Red {get;}. Once again this would be consistent with CIColor and Color,  furthermore Component seems to be a synonym for property.  Thoughts?</div>

</blockquote><div><br></div></div><div>Let us rename it.   The only case where we might have problems is with MacCore, as that API is already an API that is used by thousands of developers, so we can not just break their apps like that.</div>

<div><br></div><div>For the &quot;Component&quot; part, I am do not remember why we did it this way, but I remember that it was not my first choice, I would have to investigate again why I chose to keep it that way.    For now, let us keep it as-is.</div>
<div class="im">
<div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div>This is my first submission, so feedback would be helpful.</div></blockquote><div><br></div></div>
<div>Lovely work.   You just missed adding the new file to the src/Makefile</div>
<div><br></div><font color="#888888"><div>Miguel </div></font></div></div>
</blockquote></div><br></div></div></div>