Here is a patch for the renames in NSColor.<div><br></div><meta http-equiv="Content-Type" content="text/html;charset=UTF-8"><div>Happy New Year!</div><div><br><div class="gmail_quote">On Sat, Jan 1, 2011 at 6:40 AM, Miguel de Icaza <span dir="ltr">&lt;<a href="mailto:miguel@novell.com">miguel@novell.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">Hello,<br>Hello,<div><br><div class="gmail_quote"><div class="im"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div><div><div>There are currently 30 ObjC methods named &quot;numberOfXxx&quot; in appkit.cs, and 1 in coreimage.cs and there does not seem to be a standard for the C# name.  I have seen</div>
<div>
<br></div><div>  NumberOfXxx</div><div>  Xxx</div><div>  CountOfXxx</div><div>  XxxCount</div><div>  Count</div></div></div></blockquote><div><br></div></div><div>Thanks for surveying the API.    It might be useful to keep track of these conventions, as I find myself not remembering what certain things should be.  </div>
<div class="im">
<div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div><div>Leaving it NumberOfXxx, doesn&#39;t seem very C#ish, and Count is only appropriate if the object is clearly a collection.  Dropping the NumberOf is usually confusing, for example shortening the NSColor method numberOfComponents to just Components is mis-leading because it does not return the components (which is an array of floats).  Granted intellisense helps, but I think a good standard name helps make the code more readable.  So, what should it be?</div>

</div></div></blockquote><div><br></div></div><div>Agreed.</div><div class="im"><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div><div>My vote is Count or XxxCount, depending on the object.</div>

</div></div></blockquote><div><br></div></div><div>XxxCount is my preference, as I remember clearly not using &quot;Count&quot; as I found the resulting code ambiguous sometimes.</div><div><br></div><font color="#888888"><div>
Miguel</div></font></div></div>
</blockquote></div><br></div>