Thanks Michael, I appreciate you taking the time to reply.<div><br></div><div><span style="border-collapse:collapse;font-family:arial, sans-serif;font-size:13px">I have created a script just to run our mono test exe on Mac to see if adding DYLD_FALLBACK_LIBRARY_PATH will solve our issue. <br>

It did not solve our problem, we get exception about the libfreetype version. I did not yet create the app bundle (plist etc), it&#39;s just a sh script to run our app in project bin/debug folder. <br>Here is script code to run our app:<br>

-----------<br>#!/bin/sh <br><br>DIR=$(cd &quot;$(dirname &quot;$0&quot;)&quot;; pwd)<br>MONO_FRAMEWORK_PATH=/Library/Frameworks/Mono.framework/Versions/Current<br>export DYLD_FALLBACK_LIBRARY_PATH=&quot;$DIR:$MONO_FRAMEWORK_PATH/lib:/lib:/usr/lib&quot;<br>

export PATH=&quot;$MONO_FRAMEWORK_PATH/bin:$PATH&quot;<br>exec mono &quot;$DIR/test.exe&quot;<br>------------------<br><br>Now I wanted to see the mono debug info but for some reason I&#39;m not able to see/get any debug info. <br>

If I manually run a command in Terminal: &#39;MONO_LOG_LEVEL=debug test.exe&#39; I will see lots of debug info which is useful to debug problems. <br><br>I wanted to get the same debug info when running script but I can&#39;t get anything. Was trying several options with MONO_LOG_LEVEL=debug and without it. With --debug etc. <br>

When running script below debuglog.txt file is created but there no debug info, file is empty. When running this script I only see new Terminal window and then our test app will start. There is no debug info anywhere. <br>

Debug script version:<br>------------<br>#!/bin/sh<br> <br>DIR=$(cd &quot;$(dirname &quot;$0&quot;)&quot;; pwd)<br>MONO_FRAMEWORK_PATH=/Library/Frameworks/Mono.framework/Versions/Current<br>export DYLD_FALLBACK_LIBRARY_PATH=&quot;$DIR:$MONO_FRAMEWORK_PATH/lib:/lib:/usr/lib&quot;<br>

export PATH=&quot;$MONO_FRAMEWORK_PATH/bin:$PATH&quot;<br>MONO_LOG_LEVEL=debug<br>exec mono --debug &quot;$DIR/test.exe&quot; $* 2&gt;&amp;1 1&gt; &quot;$DIR/debuglog.txt&quot;<br>------------<br><br>Will Terminal window be displayed when running this sh script via Mac .app bundle ? </span></div>

<div><font face="arial, sans-serif"><span style="border-collapse:collapse"><br></span></font></div><div><font face="arial, sans-serif"><span style="border-collapse:collapse">Any help is appreciated. </span></font></div>
<div><font face="arial, sans-serif"><span style="border-collapse:collapse"><br clear="all"></span></font>Brian O&#39;Neill<br>FreshIdeas: Website Development,<br>Internet Strategy &amp; Online Marketing<br>
Email: <a href="mailto:brian@freshideas.ie" target="_blank">brian@freshideas.ie</a><br>Website: <a href="http://www.freshideas.ie/" target="_blank">http://www.freshideas.ie</a><br><br>
<br><br><div class="gmail_quote">On 25 February 2011 11:54, Brian O&#39;Neill <span dir="ltr">&lt;<a href="mailto:brian@freshideas.ie" target="_blank">brian@freshideas.ie</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

Hi I am new to mono development and was hoping to get some advice.<div><br></div><div><div>We are trying to develop GTK# 2.0 application with mono 2.10 working on Mac Snow Leoplard 10.6+. We are using a 3rd party .NET dll in our mono project on Mac. This 3rd party dll is referencing libgdiplus library which is later referencing libfreetype.dylib library located at /usr/X11/lib/libfreetype.dylib (at least this location is shown in mono debug mode when running our app). </div>


<div><br></div><div>Currently we face 2 issues: </div><div><br></div><div>1) we get an error that libfreetype.dylib version is old, mono debug says there is 10.0 but it should be 13.0  </div><div>Question is can we just overwrite that lib with new one in package installer on mac? We have copied libfreetype.dylib from X11 xquartz 2.6.0 and that solved this issue (just to clear things out installing xquartz 2.6.0 does not solve out issue, we still get that error).</div>


<div>Can we somehow add a reference to new libfreetype.dylib from mono project? </div><div> </div><div>2) after manual update to libfreetype.dylib version 13.0 we get another error that /usr/share/fonts/ttf are missing, but there is no such folder in default X11 install, again we did a manual copy of fonts folder from xquartz 2.6.0 install, after that our application was working fine. </div>


<div>Question is can we bundle fonts folder in the package installer and install it on mac without any issues? </div><div><br></div><div>Any help or clues would be very helpful.</div><div><br></div><div>Thanks</div><div>

<br>
</div>Brian O&#39;Neill<br>FreshIdeas: Website Development,<br>Internet Strategy &amp; Online Marketing<br>Email: <a href="mailto:brian@freshideas.ie" target="_blank">brian@freshideas.ie</a><br>Website: <a href="http://www.freshideas.ie/" target="_blank">http://www.freshideas.ie</a><br>



</div>
</blockquote></div><br></div>