Good god that is ugly. Let's try that again. Always hit Preview Message.  <br /><br />
After chatting with a few helpful chaps on the irc channel I feel that I am very close to getting this working. After a few hours of work last night here is a write up of what I am trying. Again, any ideas would be helpful.<br /><br />

My Goal = A working mono environment available in /Users/Shared/ on OS X (10.6).
<br /><br />
The conversation I had last night is available at pastern: <a href="http://pastebin.com/N5mUTNH0" target="_top" rel="nofollow" link="external">http://pastebin.com/N5mUTNH0</a>
<br /><br />
After this conversation it seems that I should indeed be able to accomplish my goal. Here are the steps I am going through. Where am I going wrong?
<br /><br />
Step 1: Setting up my mono environment.
-Using the directions for setting up a parallel mono environment available at: <a href="http://www.mono-project.com/Parallel_Mono_Environments" target="_top" rel="nofollow" link="external">http://www.mono-project.com/Parallel_Mono_Environments</a> I created the following bash script.
<br /><br />
#!/bin/bash
MONO_PREFIX=/Users/Shared/OpenSim/supportfiles/mono
export DYLD_FALLBACK_LIBRARY_PATH=$MONO_PREFIX/lib:$DYLD_FALLBACK_LIBRARY_PATH
export LD_LIBRARY_PATH=$MONO_PREFIX/lib:$LD_LIBRARY_PATH
export PATH=$MONO_PREFIX/bin:$PATH
export MONO_CONFIG=$MONO_PREFIX/etc/mono
PS1="[mono] \w @ "
<br /><br />
I saved this as mono-dev-env into ~. Before running mono I entered the environment using: source ~/mono-dev-env
<br /><br />
Step 2: Getting and moving mono<br />
-I was trying to build from source but after the conversation on irc last night it seems I should be able to do the following.
<br /><br />
1. Download Mono 2.6.7 Intel Framework (http://ftp.novell.com/pub/mono/archive/2.6.7/macos-10-x86/3/MonoFramework-2.6.7_3.macos10.novell.x86.dmg).<br />
2. Right-click the package > Show Package Contents. Open the contents folder. Double-click Archive.pax.gz to unarchive the file. It opens into ~/Download. Open this folder (it is named Library)<br />
3. Navigate to Frameworks/Mono.Framework/Versions/2.6.7. Copy the contents to /Users/Shared/Opensim/supportfiles/mono
<br /><br />
Step 3: Running mono from /Users/Shared<br />
-After entering my mono-dev-env from the CLI I enter the bin directory of OpenSim (the application I am trying to use) and start OpenSim with this:<br />
$ /Users/Shared/OpenSim/supportfiles/mono/bin/bin OpenSim.exe
<br /><br />
Here is the latest roadblock:
<br /><br />
[mono] /Users/Shared/MLTI_Sim/supportfiles/diva-r13981/bin @ /Users/Shared/OpenSim/supportfiles/mono/bin/mono OpenSim.exe
The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/Library/Frameworks/Mono.framework/Versions/2.6.7/lib/mono/2.0/mscorlib.dll' directory.
<br /><br />
A quick search has led me to believe I am missing one of the mscor libs that come with nant (as found here: http://opensimulator.org/wiki/Troubleshooting#The_assembly_mscorlib.dll_was_not_found_or_could_not_be_loaded). However, the file exists in /Users/Shared/OpenSim/supportfiles/mono/lib/mono/2.0/mscorlib.dll. Mono is still looking for it in the default install location. 
<br /><br />
Thoughts at this point?
<br /><br />
Also, would this be easier if one of the .dylib search paths was the mono framework instead are hard coded paths? It seems that moving a mono install on Windows is easy cheesy. The document I found here: <a href="http://www.mono-project.com/Interop_with_Native_Libraries#Mac_OS_X_Framework_and_.dylib_Search_Path " target="_top" rel="nofollow" link="external">http://www.mono-project.com/Interop_with_Native_Libraries#Mac_OS_X_Framework_and_.dylib_Search_Path </a>lead me to believe I have to set my environment variables.
<br /><br />
ps. I have also tried this with mono 2.4.3, 2.8, 2.10 with similar results.

        
<br/><hr align="left" width="300" />
View this message in context: <a href="http://mono.1490590.n4.nabble.com/Building-Mono-for-Users-Shared-tp3405521p3414941.html">Re: Building Mono for /Users/Shared</a><br/>
Sent from the <a href="http://mono.1490590.n4.nabble.com/Mono-OSX-f1546893.html">Mono - OSX mailing list archive</a> at Nabble.com.<br/>