Hi,<br><br>I&#39;m trying to package an app which used to package correctly, but now &quot;gcc exits with code 1&quot;.<br><br>Here&#39;s the build output (standard settings):<br><br><div><div><br></div><div><b>Creating app bundle</b></div>
<div>
Contents/Info.plist</div><div>Contents/PkgInfo</div><div>Contents/Resources/MainMenu.nib</div><div>Contents/Resources/MainWindow.nib</div><div>Contents/Resources/Preferences.nib</div><div>Contents/Resources/iproxify.icns</div>

<div><br></div><div><b>Merging Mono into app bundle</b></div><div>mmp -o &quot;/tmp/monomac-build-634384853555305180&quot; -n &quot;iProxify&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.dll&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.Xml.dll&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.Core.dll&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.Xml.Linq.dll&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.Drawing.dll&quot; -a &quot;/Users/robinbyte/.config/MonoDevelop/addins/MonoDevelop.MonoMac.2.4.2.2/MonoMac.dll&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.Web.dll&quot; &quot;/users/robinbyte/Desktop/iProxify/iProxify/bin/Debug/iProxify.exe&quot;</div>

<div>Process exited with code 1, command:</div><div>gcc -mmacosx-version-min=10.5 -m32 /tmp/monomac-build-634384853555305180/iProxify.app/Contents/MacOS/driver.m -o /tmp/monomac-build-634384853555305180/iProxify.app/Contents/MacOS/iProxify -D_THREAD_SAFE -I/Library/Frameworks/Mono.framework/Versions/2.10.1/include/mono-2.0   /Library/Frameworks/Mono.framework/Versions/2.10.1/lib/libmono-2.0.a -framework AppKit -liconv</div>

<div><br></div><div><b>Signing app bundle</b></div><div>codesign -v -f -s &quot;3rd Party Mac Developer Application: Yvan JANSSENS&quot; &quot;/tmp/monomac-build-634384853555305180/iProxify.app&quot;</div><div>/tmp/monomac-build-634384853555305180/iProxify.app: object file format invalid or unsuitable</div>

<div>/tmp/monomac-build-634384853555305180/iProxify.app: object file format invalid or unsuitable</div><div><br></div><div><br></div><div><b><font color="#FF0000">Signing failed</font></b></div><div><br></div>If I try to link the frameworks, I get the following output:</div>
<div><br></div><div><div><br></div><div><b>Creating app bundle</b></div><div>Contents/Info.plist</div><div>Contents/PkgInfo</div><div>Contents/Resources/MainMenu.nib</div><div>Contents/Resources/MainWindow.nib</div><div>Contents/Resources/Preferences.nib</div>
<div>Contents/Resources/iproxify.icns</div><div><br></div><div><b>Merging Mono into app bundle</b></div><div>mmp --linksdkonly -o &quot;/tmp/monomac-build-634384863830607200&quot; -n &quot;iProxify&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.dll&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.Xml.dll&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.Core.dll&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.Xml.Linq.dll&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.Drawing.dll&quot; -a &quot;/Users/robinbyte/.config/MonoDevelop/addins/MonoDevelop.MonoMac.2.4.2.4/MonoMac.dll&quot; -a &quot;/Library/Frameworks/Mono.framework/Versions/2.10.1/lib/mono/4.0/System.Web.dll&quot; &quot;/users/robinbyte/Desktop/iProxify/iProxify/bin/Debug/iProxify.exe&quot;</div>
<div><br></div><div>Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object</div><div>  at MonoMac.Bundler.Driver.Link () [0x00000] in &lt;filename unknown&gt;:0 </div><div>
  at MonoMac.Bundler.Driver.Main (System.String[] args) [0x00000] in &lt;filename unknown&gt;:0 </div><div><br></div><div>Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object</div>
<div>  at MonoMac.Bundler.Driver.Link () [0x00000] in &lt;filename unknown&gt;:0 </div><div>  at MonoMac.Bundler.Driver.Main (System.String[] args) [0x00000] in &lt;filename unknown&gt;:0 </div><div><br></div><div><br></div>
<div><b><font class="Apple-style-span" color="#FF0000">Merging Mono failed</font></b></div><br></div><div><div><br>I&#39;m runnng 10.6.6 Snow Leopard, and latest 2.4.2 MonoDevelop, and Application tools 1.1/Xcode 3.2.5 . I manually updated monomac from source.</div>
<div>Do you guys have any clue where to search?</div><div><br></div><div>Thanks,</div><div><br></div><div>Yvan</div>
-- <br>Never be afraid to try something new. Remember amateurs built the ark - Professionals built the Titanic.<br><br></div>