Wow, that was a long time ago.... I don&#39;t remember exactly. :) I think it was a memory leak though. When you redirect the output you have to close the stream, then close &amp; dispose of the process. I.e., taking the original example:<div>

<br></div><div><span class="Apple-style-span" style="font-family: arial, sans-serif; font-size: 13px; background-color: rgb(255, 255, 255); ">               using (var ioreg = Process.Start(ioregInfo)) {<br></span><span class="Apple-style-span" style="font-family: arial, sans-serif; font-size: 13px; background-color: rgb(255, 255, 255); ">                   // ...<br>

                   ioreg.StandardOutput.Close();</span></div><div><span class="Apple-style-span" style="font-family: arial, sans-serif; font-size: 13px; background-color: rgb(255, 255, 255); ">                   ioreg.Close();</span></div>

<div><span class="Apple-style-span" style="font-family: arial, sans-serif; font-size: 13px; background-color: rgb(255, 255, 255); ">                   ioreg.Dispose();  </span></div><div><span class="Apple-style-span" style="font-family: arial, sans-serif; font-size: 13px; background-color: rgb(255, 255, 255); ">               }</span></div>

<div></div><div><font class="Apple-style-span" face="arial, sans-serif"><br></font><br><div class="gmail_quote">On Wed, Sep 7, 2011 at 9:49 PM, Srini [via Mono] <span dir="ltr">&lt;<a href="/user/SendEmail.jtp?type=node&node=3798609&i=0" target="_top" rel="nofollow" link="external">[hidden email]</a>&gt;</span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

        Even i am getting same error. Did you find any solution for this? If yes kindly share the solution
<br><br>-Srini
        
        <br>
        <br>
        <hr noshade size="1" color="#cccccc">
        <div style="color:#444;font:12px tahoma,geneva,helvetica,arial,sans-serif">
                <div style="font-weight:bold">If you reply to this email, your message will be added to the discussion below:</div>
                <a href="http://mono.1490590.n4.nabble.com/Process-Start-causes-SIGSEGV-tp3251954p3797812.html" target="_blank" rel="nofollow" link="external">http://mono.1490590.n4.nabble.com/Process-Start-causes-SIGSEGV-tp3251954p3797812.html</a>
        </div>
        <div style="color:#666;font:11px tahoma,geneva,helvetica,arial,sans-serif;margin-top:.4em">
                
                To unsubscribe from Process.Start causes SIGSEGV, <a href="" target="_blank" rel="nofollow" link="external">click here</a>.
        </div></blockquote></div><br></div>

        
<br/><hr align="left" width="300" />
View this message in context: <a href="http://mono.1490590.n4.nabble.com/Process-Start-causes-SIGSEGV-tp3251954p3798609.html">Re: Process.Start causes SIGSEGV</a><br/>
Sent from the <a href="http://mono.1490590.n4.nabble.com/Mono-OSX-f1546893.html">Mono - OSX mailing list archive</a> at Nabble.com.<br/>