<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">I'm new to Mono framework (as well as Mac development in general) and am evaluating Mono for cross platform development between Windows and Mac.  Eventually will want to branch out to other mobile devices (iPhone and Android).  <div><br></div><div>One requirement we have is to keep our deployments as light weight as possible (i.e. avoiding deploying extra packages and versioning issues / may be dependent onů)  For this reason i'm looking at using the AOT compiler and/or bundling everything into a single deployment package.<div><div><br></div><div><div>When running the AOT option I get an error message that 'as' command not found.  Any idea where the 'as' (assembler) is located and where it gets set up?</div><div><div><br></div><div><div>rics-MacBook-Pro:Debug ericvandenberg$ <b>mono --aot TestApp.exe</b></div><div>Mono Ahead of Time compiler - compiling assembly /Users/ericvandenberg/Projects/TestApp/TestApp/bin/Debug/TestApp.exe</div><div>Code: 1514 Info: 45 Ex Info: 30 Unwind Info: 37 Class Info: 30 PLT: 19 GOT Info: 290 GOT: 156 Offsets: 94</div><div>Executing the native assembler: as -arch i386 -W  -o /var/folders/bh/8078t6q17qv6gzvp72zsrjjh0000gn/T/mono_aot_sb17Ot.o /var/folders/bh/8078t6q17qv6gzvp72zsrjjh0000gn/T/mono_aot_sb17Ot</div><div><b>sh: as: command not found</b></div><div>AOT of image TestApp.exe failed.</div></div></div><div><br></div><div>Any help would be appreciated.</div><div><br></div><div>Thanks,</div><div>Eric</div><div><br></div><div><br></div></div></div></div></body></html>