Hello... Just installed the latest monodevelop, mono MRE 2.10.9_8 and MDK-20.10.9_8

Any help would be much appreciated ....

mono x.exe works fine
mkbundle --deps x.exe -o xxx works fine after exporting as and cc -arch=i386
mkbundle --deps --static x.exe -o xxx FAILS with the following errors...

Undefined symbols for architecture i386:
  "_CFLocaleCopyCurrent", referenced from:
      _ves_icall_System_Globalization_CultureInfo_construct_internal_locale_from_current_locale in libmono-2.0.a(libmonoruntime_la-locales.o)
  "_CFLocaleGetIdentifier", referenced from:
      _ves_icall_System_Globalization_CultureInfo_construct_internal_locale_from_current_locale in libmono-2.0.a(libmonoruntime_la-locales.o)
  "_CFStringGetLength", referenced from:
      _ves_icall_System_Globalization_CultureInfo_construct_internal_locale_from_current_locale in libmono-2.0.a(libmonoruntime_la-locales.o)
  "_CFStringGetMaximumSizeForEncoding", referenced from:
      _ves_icall_System_Globalization_CultureInfo_construct_internal_locale_from_current_locale in libmono-2.0.a(libmonoruntime_la-locales.o)
  "_CFStringGetCString", referenced from:
      _ves_icall_System_Globalization_CultureInfo_construct_internal_locale_from_current_locale in libmono-2.0.a(libmonoruntime_la-locales.o)
  "_CFRelease", referenced from:
      _ves_icall_System_Globalization_CultureInfo_construct_internal_locale_from_current_locale in libmono-2.0.a(libmonoruntime_la-locales.o)
  "_locale_charset", referenced from:
      _monoeg_g_get_charset in libmono-2.0.a(libeglib_la-gunicode.o)
  "_iconv_open", referenced from:
      _monoeg_g_convert in libmono-2.0.a(libeglib_la-gunicode.o)
  "_iconv", referenced from:
      _monoeg_g_convert in libmono-2.0.a(libeglib_la-gunicode.o)
  "_iconv_close", referenced from:
      _monoeg_g_convert in libmono-2.0.a(libeglib_la-gunicode.o)
ld: symbol(s) not found for architecture i386
collect2: ld returned 1 exit status

        
<br/><hr align="left" width="300" />
View this message in context: <a href="http://mono.1490590.n4.nabble.com/osx-mkbundle-static-deps-fails-tp4510463p4510463.html">osx mkbundle --static --deps fails</a><br/>
Sent from the <a href="http://mono.1490590.n4.nabble.com/Mono-OSX-f1546893.html">Mono - OSX mailing list archive</a> at Nabble.com.<br/>