<div dir="ltr">This is due to bug <a href="https://bugzilla.xamarin.com/show_bug.cgi?id=17225">17225</a>. This is happening when either of System.Drawing.Color or System.Drawing.Bitmap is used for the first time on the system at which time the font cache will be built. This can take up to approx 3-6 minutes. After this initial build of the font cache this will not happen again, i.e, it will usually only happen the first time the user launches the application but not for any subsequent launches.<div><br></div><div>The only current work around to avoid this is to completely avoid using System.Drawing.Color or System.Drawing.Bitmap in the application (not even in resx files). </div><div><br></div><div><div><br><div>/Johan </div></div></div><div><br></div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Mar 10, 2015 at 2:28 PM, Stefanos A. <span dir="ltr"><<a href="mailto:stapostol@gmail.com" target="_blank">stapostol@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div><div>I have encountered this issue before. It appears that System.Drawing.dll is hanging during initialization (inside libgdiplus).<br><br></div><div>I have not had access to a Mac OS X system during the past several months, so I have not had a chance to investigate further.<br><br></div></div></div><div class="gmail_extra"><br><div class="gmail_quote"><span class="">2015-03-08 17:44 GMT+01:00 David Jeske <span dir="ltr"><<a href="mailto:davidj@gmail.com" target="_blank">davidj@gmail.com</a>></span>:<br></span><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class=""><div dir="ltr">When I launch OpenTK apps on OSX with Mono 3.12.x, they never create their window, instead I just get a wait cursor. They work fine after backreving to Mono 3.10.0. <div><br></div><div>Any ideas why?</div><div><br></div><div><br></div></div>
<br></span>_______________________________________________<br>
Mono-osx mailing list<br>
<a href="mailto:Mono-osx@lists.ximian.com" target="_blank">Mono-osx@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-osx" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-osx</a><br>
<br></blockquote></div><br></div>
<br>_______________________________________________<br>
Mono-osx mailing list<br>
<a href="mailto:Mono-osx@lists.ximian.com">Mono-osx@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-osx" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-osx</a><br>
<br></blockquote></div><br></div></div>