<div dir="ltr"><div class="gmail_default" style="font-family:tahoma,sans-serif">Thanks for the clarification on the changes.</div><div class="gmail_default" style="font-family:tahoma,sans-serif"><br></div><div class="gmail_default" style="font-family:tahoma,sans-serif">For the hot reload I was changing the code in the constructor which caused UE to stop playing.  If I change the code in the tick method it works as expected. </div></div><div class="gmail_extra"><br><div class="gmail_quote">On Sat, Nov 1, 2014 at 4:53 PM, Michael Hutchinson <span dir="ltr"><<a href="mailto:m.j.hutchinson@gmail.com" target="_blank">m.j.hutchinson@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Sorry, the API has been tweaked a little since writing the Getting<br>
Started. Category is now a separate attribute e.g.<br>
<br>
[UProperty, Category ("Static Mesh")]<br>
<span class="">public Subobject<StaticMeshComponent> MeshComponent { get; set; }<br>
<br>
</span>And the "this" parameter is now implicitly provided by the PCIP:<br>
<br>
MeshComponent = pcip.CreateDefaultSubobject<StaticMeshComponent> (new<br>
Name ("StaticMeshComponent0"));<br>
<br>
In what way does hot reload not work? There should be log messages in<br>
the UE Output Log when the IDE notifies UE to perform the hot-reload,<br>
are those messages there?<br>
<div><div class="h5"><br>
<br>
On 1 November 2014 14:51, Duane Wandless <<a href="mailto:duane@wandless.net">duane@wandless.net</a>> wrote:<br>
> I'm trying to implement the simple getting started example on Win64.  I<br>
> receive these compile errors, <a href="http://pastebin.com/H3fsXJ1k" target="_blank">http://pastebin.com/H3fsXJ1k</a>.<br>
><br>
> The compile is failing on these two lines (full source):<br>
> [UProperty(Category = "Static Mesh")]<br>
> public Subobject<StaticMeshComponent> MeshComponent { get; set; }<br>
> and<br>
> MeshComponent = pcip.CreateDefaultSubobject<StaticMeshComponent>(this, new<br>
> Name("StaticMeshComponent0"));<br>
><br>
> UProperty does not contain Category (UProperty from Assembly browser).  And<br>
> no signature matches on pcip.  If I remove Category and modify the signature<br>
> to be CreateDefaultSubobject...(new Name("...") I am able to get the C# code<br>
> to impact the UE project, though hot reload does not work.<br>
><br>
> Any ideas on why the bindings are incomplete?<br>
><br>
> Thanks,<br>
> Duane<br>
><br>
> Also- well done on the past few years!<br>
><br>
><br>
><br>
><br>
</div></div>> _______________________________________________<br>
> Mono-ue mailing list<br>
> <a href="mailto:Mono-ue@lists.ximian.com">Mono-ue@lists.ximian.com</a><br>
> <a href="http://lists.ximian.com/mailman/listinfo/mono-ue" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-ue</a><br>
><br>
<span class="HOEnZb"><font color="#888888"><br>
<br>
<br>
--<br>
Michael Hutchinson ~ <a href="https://mhut.ch" target="_blank">https://mhut.ch</a><br>
</font></span></blockquote></div><br></div>