<html>
<head>
<style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 12pt;
font-family:Calibri
}
--></style></head>
<body class='hmmessage'><div dir='ltr'>I have Monodevelop Windows Platform Support version 5.6.3 and Unreal Engine Version 1.0 in my XS Add-in Manager.<br><br><div><hr id="stopSpelling">From: stick100@hotmail.com<br>To: m.j.hutchinson@gmail.com<br>CC: mono-ue@lists.ximian.com<br>Subject: RE: [Mono-ue] Anyone had any success with anything except Play In Editor?<br>Date: Wed, 10 Dec 2014 05:50:30 -0600<br><br>

<style><!--
.ExternalClass .ecxhmmessage P {
padding:0px;
}

.ExternalClass body.ecxhmmessage {
font-size:12pt;
font-family:Calibri;
}

--></style>
<div dir="ltr"><div>What do you mean stage a "Game" build?  Is that just using the "Launch" button or UEF to make a build?<br></div><div><br></div>If I "debug" from XS I do not hit any break points.  It appears to have loaded an older version of the map.  I did find the line: <div><br></div><div><font color="#008a17">Cmd: OBJ SAVEPACKAGE<br>PACKAGE="/Game/Maps/Example_Map" FILE="../../../../Unreal<br>Projects/NewCodeFlying/Saved/Autosaves/Game/Maps/UEDPCExample_Map.umap"<br>SILENT=true AUTOSAVING=true KEEPDIRTY=true</font><br><div><br></div><div>Appears in the output log of the Unreal Editor the second I debug from XS.</div><div><br></div><div><span style="font-size:12pt;">In the XS output I have the following errors (that were highlighted in red):</span></div><div><div><font color="#d24726"><br></font></div><div><font color="#d24726">[2014.12.10-11.40.25:359][  0]MonoErrors: New page: Mono Runtime Errors</font></div><div><br></div><div><div><font color="#d24726">[2014.12.10-11.40.25:892][  0]MonoErrors:Error: Error '../../../../Unreal Projects/NewCodeFlying/Binaries/MonoGameAssemblies/NewCodeFlyingMono.dll': System.ExecutionEngineException: Failed to create shadow copy (CopyFile).</font></div><div>  at (wrapper managed-to-native) System.AppDomain:LoadAssembly (System.AppDomain,string,System.Security.Policy.Evidence,bool)</div><div>  at System.AppDomain.Load (System.String assemblyString, System.Security.Policy.Evidence assemblySecurity, Boolean refonly) [0x00027] in /Users/michael/Mono/mono/mcs/class/corlib/System/AppDomain.cs:800 </div><div>  at System.AppDomain.Load (System.String assemblyString) [0x00000] in /Users/michael/Mono/mono/mcs/class/corlib/System/AppDomain.cs:781 </div><div>  at (wrapper remoting-invoke-with-check) System.AppDomain:Load (string)</div><div>  at System.Reflection.Assembly.Load (System.String assemblyString) [0x00000] in /Users/michael/Mono/mono/mcs/class/corlib/System.Reflection/Assembly.cs:541 </div><div>  at UnrealEngine.Runtime.Bindings.LoadAssembly (System.String assemblyName) [0x00000] in <filename unknown>:0 </div></div><div><br></div><div><div><font color="#ac193d">[2014.12.10-11.40.28:541][  0]LoadErrors: Info Failed to load /Script/NewCodeFlyingMono.TestActor Referenced by PersistentLevel</font></div></div><div><font color="#ac193d"><br></font></div><div><div><font color="#ac193d">[2014.12.10-11.40.28:541][  0]LoadErrors: Info Failed to load /Script/NewCodeFlyingMono.TestActor Referenced by PersistentLevel</font></div><div><br></div><div>I've attached the whole log from XS in the txt file.</div><br><div>> From: m.j.hutchinson@gmail.com<br>> Date: Tue, 9 Dec 2014 14:58:20 -0500<br>> To: stick100@hotmail.com<br>> CC: mono-ue@lists.ximian.com<br>> Subject: Re: [Mono-ue] Anyone had any success with anything except Play In    Editor?<br>> <br>> We've mainly been focused on the "Editor" build, the "Client"/"Server"<br>> targets are not something we've tested. However, if you stage a "Game"<br>> build that should work.<br>> <br>> When debugging from Xamarin Studio, we actually instruct the editor to<br>> start a new standalone process and connect the debugger to that, so it<br>> shoudn't be affected by existing editor state. The log output of that<br>> gets written to a log file and XS tries to read that into the<br>> "Application Output" pad - do you see any errors there?<br>> <br>> Sorry about Ludum Dare :/<br>> <br>> - m<br>> <br>> On 7 December 2014 at 15:48, M S <stick100@hotmail.com> wrote:<br>> > Has anyone had any success with anything except Play In Editor?  I've built<br>> > from 4.4 source several times with the patches probably spent around 10<br>> > hours building/patching and the best I've ever gotten is a build that will<br>> > take my scripts and not hot reload (but stop the session and apply).<br>> > However if I debug from Xamarin Studio I don't hit breakpoints because<br>> > something is causing an old map to be used (without the new test actor).  I<br>> > can see a line in the output log that says "Cmd: OBJ SAVEPACKAGE<br>> > PACKAGE="/Game/Maps/Example_Map" FILE="../../../../Unreal<br>> > Projects/NewCodeFlying/Saved/Autosaves/Game/Maps/UEDPCExample_Map.umap"<br>> > SILENT=true AUTOSAVING=true KEEPDIRTY=true" when I debug from Xamarin<br>> > studio.  For some reason it want's to revert my save file.<br>> ><br>> > Best I've been able to do when hitting the "launch" button is that it will<br>> > launch to a black screen and throw an assertion.<br>> ><br>> > Best I can do for building the "Development Client" is that I got it to<br>> > launch with my map, but the Xamarin behavior is not acting (chair not<br>> > spinning).<br>> ><br>> > TLDR: I can get Xamarin behavior working in the Editor Play Session but<br>> > that's it so far.<br>> ><br>> > Has anyone actually gotten an independent .exe file with any Xamarin<br>> > behavior to be built yet?<br>> ><br>> > I had hoped to build something for Ludum Dare but I've spent all weekend<br>> > just trying to get a single .exe build with any kind of Xamarin behavior.<br>> ><br>> > Thanks,<br>> > Mark Sebesta<br>> ><br>> > _______________________________________________<br>> > Mono-ue mailing list<br>> > Mono-ue@lists.ximian.com<br>> > http://lists.ximian.com/mailman/listinfo/mono-ue<br>> ><br>> <br>> <br>> <br>> -- <br>> Michael Hutchinson ~ https://mhut.ch<br>> _______________________________________________<br>> Mono-ue mailing list<br>> Mono-ue@lists.ximian.com<br>> http://lists.ximian.com/mailman/listinfo/mono-ue<br></div></div></div></div>                                        </div></div>                                        </div></body>
</html>