<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 15 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
p.MsoListParagraph, li.MsoListParagraph, div.MsoListParagraph
        {mso-style-priority:34;
        margin-top:0cm;
        margin-right:0cm;
        margin-bottom:0cm;
        margin-left:36.0pt;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
span.EmailStyle18
        {mso-style-type:personal;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
span.EmailStyle19
        {mso-style-type:personal-reply;
        font-family:"Calibri",sans-serif;
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-AU link="#0563C1" vlink="#954F72"><div class=WordSection1><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'>Yeah I suspect the issue is with the CompileAction.CommandArguments. It build a large list of CompileActions. Each have the same CompileAction.CommandPath which looks like it’s the C++ compiler. I tried outputting the CommandArguments but each one has a huge list of arguments. I couldn’t find where it actually uses CompileAction to execute RC so I could stick some error handling around the failing one. I’m not sure how to debug the UnrealBuildTool without knowing what command line arguments it is using. <o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'><o:p> </o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'>I rolled back 2 commits and got a different build error, so I’m not sure if it started there. I was defiantly able to build before, I think it was preview 4<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'>Error      1              error CS0115: 'UnrealBuildTool.Plugin.Rules.MonoRuntime.PreBuildTarget(UnrealBuildTool.UEBuildTarget, System.Collections.Generic.List<UnrealBuildTool.FileItem>)': no suitable method found to override       e:\Source Control\UnrealEngine\Engine\Plugins\XamarinUE4\MonoRuntime\Source\MonoRuntime\MonoRuntime.Plugin.cs                378         38           UE4<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'> <o:p></o:p></span></p><p class=MsoNormal><a name="_MailEndCompose"><span style='color:#1F497D;mso-fareast-language:EN-US'><o:p> </o:p></span></a></p><div><div style='border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0cm 0cm 0cm'><p class=MsoNormal><b><span lang=EN-US>From:</span></b><span lang=EN-US> mono-ue-bounces@lists.ximian.com [mailto:mono-ue-bounces@lists.ximian.com] <b>On Behalf Of </b>Robert Vissers<br><b>Sent:</b> Tuesday, 10 March 2015 6:54 AM<br><b>To:</b> mono-ue@lists.ximian.com<br><b>Subject:</b> [Mono-ue] Build Error<o:p></o:p></span></p></div></div><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal><span lang=EN-US>I have the same build error on 2 of my PC’s. I got it to work on one other for some reason. I have no idea what the difference is. All VS2013, even one without update 4 (failed).<o:p></o:p></span></p><p class=MsoNormal><span lang=EN-US><o:p> </o:p></span></p><p class=MsoNormal><span lang=EN-US>CompileAction.CommandPath output is quite useless, is there some way to trace what the actual arguments are at the moment of failure? It compiles the RC list before executing it, making it quite hard to guess. Especially when it is running in parallel.<o:p></o:p></span></p></div></body></html>