[MonoDevelop] Help to install Monodevelop

Michael Hutchinson m.j.hutchinson at gmail.com
Tue Sep 30 03:18:12 EDT 2008

On Tue, Sep 30, 2008 at 2:53 AM, Petit Eric <surfzoid at gmail.com> wrote:
>>> I using Fedora 4 (64bits) and i try to install monodevelop version 1.0.
>>> After upgrade the glib, gtk and others packages i can install the
>>> monodevelop. But when i try to use a exception ocorrence like undefined
>>> symbol gtk_widget_modify_cursor.
>>> I invesgate by my self, and discovery that the libray gtksourceview don't
>>> link with this functions. In my libgtk-x11-2.0.so i find this function
>>> normal, but i can't link with the gtksourceview. I think that i'm doing
>>> something wrong when i'try to compile gtksourceview.
>>> Anyone have any idea for i can compile the gtksourceview corret?
> you should try to use svn list svn://anonsvn.mono-project.com/source/trunk
> to get, compile and install in order, mono, libgdiplus, gtk-sharp and
> finally MD, don't select all with MD configure just use the def
> profile, i also suggest you to use --prefix=/usr and uninstall

If you use /usr, make sure you really know what you're doing. A
parallel install is generally better:

> gtksourceview, this one is now only used for something with database
> addon all the rest use the integrated Editor.

Yes, currently only the Database addin and Boo Binding require
GtkSourceView#. Note they require GtkSourceView-sharp-2.0, which uses
GtkSourceview 1.8. GtkSourceview2-sharp does exist, but is not
compatible with either one (Confusing, I know.

Michael Hutchinson

More information about the Monodevelop-list mailing list