[MonoDevelop] how to use debug in MonoDevelop 2.0

Jensen Somers jensen.somers at gmail.com
Sat Jun 6 15:27:37 EDT 2009

On Sat, Jun 6, 2009 at 21:20, Jensen Somers<jensen.somers at gmail.com> wrote:
> On Sat, Jun 6, 2009 at 21:13, danieru<samuraidanieru at gmail.com> wrote:
>> Hi,
>> How can I setup and use debugging in MonoDevelop 2.0? I'm using the Ubuntu
>> Jaunty 'monodevelop' 2.0 package, and I also installed
>> 'monodevelop-debugger-mdb' 2.0-1.
>> Now I'm in the IDE with both combo boxes set to 'debug', and I've inserted
>> break points in my code, but when I hit F5, it doesn't seem to hit any of
>> the breaks (I'm assuming they turn yellow?) and I'm not seeing any variable
>> value windows. I'm also not finding any 'step in, over,' commands in the
>> menus.
>> Also, I did find the 'Add-in Manager' from preferences. Under Debugging,
>> it's showing "MDB support for Mono.Debugging 2.0' but it appears already
>> installed, only giving me the option of 'Disable'.
>> Am I missing something here?
>> Are there instructions anywhere on how to setup/use the debugger?
>> Any help is appreciated.
> I am having the same problem. I tried both GDB and MDB but no luck.
> I did notice that the application I try to debug is using make
> commands when running, could that be an issue?
> - Jensen

Just got this confirmed on IRC.

So if the application you are trying to debug uses makefiles and make
run directly it doesn't work.

- Jensen

More information about the Monodevelop-list mailing list