I think you should ensure that the directory where the .pc files for gtk 2.10 is in the enviroment var PKG_CONFIG_PATH.<br><br>It almost worked for me using gtk-sharp from svn.<br><br>Regards.<br><br><div><span class="gmail_quote">
2007/5/22, Lluis Sanchez &lt;<a href="mailto:lluis@ximian.com">lluis@ximian.com</a>&gt;:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Hi,<br><br>Having gtk# 2.10 should be enough to load assemblies linked to 2.8. Gtk#<br>comes with some assembly loading policies that allows that, and it works<br>since there is a lot of people using 2.10 and MD works just fine. So
<br>maybe you have something wrong in your setup.<br><br>Lluis.<br><br>El dt 22 de 05 del 2007 a les 01:22 +0100, en/na qva5 va escriure:<br>&gt; When trying to install monodevelop from svn I run into such problem<br>&gt;
<br>&gt;<br>&gt; ** (/usr/local/share/mono/lib/mono/2.0/gmcs.exe:29856): WARNING **: The<br>&gt; following assembly referenced from<br>&gt; /home/qva5/monodevelop/dev/monodevelop/contrib/Mono.Addins.Gui.dll could<br>&gt; not be loaded:
<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Assembly:&nbsp;&nbsp; gtk-sharp&nbsp;&nbsp;&nbsp;&nbsp;(assemblyref_index=0)<br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Version:&nbsp;&nbsp;&nbsp;&nbsp;<a href="http://2.8.0.0">2.8.0.0</a><br>&gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Public Key: 35e10195dab3c99f<br>&gt; The assembly was not found in the Global Assembly Cache, a path listed
<br>&gt; in the MONO_PATH environment variable, or in the location of the<br>&gt; executing assembly (/home/qva5/monodevelop/dev/monodevelop/contrib/).<br>&gt;<br>&gt;<br>&gt; ** (/usr/local/share/mono/lib/mono/2.0/gmcs.exe:29856): WARNING **:
<br>&gt; Could not load file or assembly &#39;gtk-sharp, Version=<a href="http://2.8.0.0">2.8.0.0</a>,<br>&gt; Culture=neutral, PublicKeyToken=35e10195dab3c99f&#39; or one of its<br>&gt; dependencies.<br>&gt;<br>&gt;<br>&gt; I have gtk-sharp in version 
2.10. Should i just add old version 2.8 to<br>&gt; the gac and try to run &#39;make&#39; one more time? Or there is another way to<br>&gt; accomplish this installation. I would prefer not to mix assemblies,<br>&gt; having in mind problems with gtk-sharp in 
2.4 and 2.10.<br>&gt;<br>&gt;<br>&gt; Lukasz.<br>&gt; _______________________________________________<br>&gt; Monodevelop-list mailing list<br>&gt; <a href="mailto:Monodevelop-list@lists.ximian.com">Monodevelop-list@lists.ximian.com
</a><br>&gt; <a href="http://lists.ximian.com/mailman/listinfo/monodevelop-list">http://lists.ximian.com/mailman/listinfo/monodevelop-list</a><br><br>_______________________________________________<br>Monodevelop-list mailing list
<br><a href="mailto:Monodevelop-list@lists.ximian.com">Monodevelop-list@lists.ximian.com</a><br><a href="http://lists.ximian.com/mailman/listinfo/monodevelop-list">http://lists.ximian.com/mailman/listinfo/monodevelop-list
</a><br></blockquote></div><br><br clear="all"><br>-- <br>-- Saludos --