Hi Lluis,<br><br>monoupdater.sh svn updates, builds then installs mono and monodevelop for me. I found monoupdater.sh here <a href="http://www.all-the-johnsons.co.uk/mono/mono-extras.shtml">http://www.all-the-johnsons.co.uk/mono/mono-extras.shtml
</a> and have made a few hacks to bring it up to date.<br><br>I worry that my svn, make, install procedure might be somehow flawed so in <br>the spirit of full disclosure :) I&#39;ve attached my monoupdater.sh , and t3.txt
 files. <br>But the summary is:<br><br># pushd ~/monosrc<br><br># svn co svn://anonsvn.mono-<a href="http://project.com/source/trunk/mono">project.com/source/trunk/mono</a><br># svn co svn://anonsvn.mono-<a href="http://project.com/source/trunk/mcs">
project.com/source/trunk/mcs</a><br># svn co svn://anonsvn.mono-<a href="http://project.com/source/trunk/gtk-sharp">project.com/source/trunk/gtk-sharp</a><br># svn co svn://anonsvn.mono-<a href="http://project.com/source/trunk/libgdiplus">
project.com/source/trunk/libgdiplus</a><br># svn co svn://anonsvn.mono-<a href="http://project.com/source/trunk/monodevelop">project.com/source/trunk/monodevelop</a><br># svn co svn://anonsvn.mono-<a href="http://project.com/source/trunk/gtksourceview-sharp">
project.com/source/trunk/gtksourceview-sharp</a><br># svn co svn://anonsvn.mono-<a href="http://project.com/source/trunk/gtkmozembed-sharp">project.com/source/trunk/gtkmozembed-sharp</a><br># svn co svn://anonsvn.mono-<a href="http://project.com/source/trunk/monodoc">
project.com/source/trunk/monodoc</a><br>All Checked out revision 80689.<br><br>Mostly do the following for each of the products listed, above.<br>&nbsp;&nbsp;&nbsp; # pushd libgdiplus<br>&nbsp;&nbsp;&nbsp; # make&nbsp; all-recursive<br>&nbsp;&nbsp;&nbsp; # su -c make install
<br>&nbsp;&nbsp;&nbsp; # su -c /sbin/ldconfig<br><br>I don&#39;t know how monodevelop knows to look for version .14, or .13 so<br>thinking this logic might be bound to the source I tried something else,<br>which still fails with the same errors.
<br><br># rm -Rf ~/monosrc/monodevelop<br>root at BrainIac:/home/dalem/monosrc# time /home/dalem/bin/monoupdater.sh<br>&gt;t2.txt 2&gt;&gt;t2.txt<br><br>But that has helped none.<br><br>I&#39;m sorry to be such a dweeb, but; I&#39;m still drowning here:(
<br><br>Many thanks for any help you can provide,<br>Dale E. Moore<br><br><br>On 6/28/07, Lluis Sanchez &lt;<a href="mailto:lluis@ximian.com">lluis@ximian.com</a>&gt; wrote:<br><br>&nbsp;&nbsp;&nbsp; What does monoupdater.sh do?<br><br>
&nbsp;&nbsp;&nbsp; El dc 27 de 06 del 2007 a les 20:51 -0700, en/na DaleEMoore va escriure:<br>&nbsp;&nbsp;&nbsp; &gt; Hi All,<br>&nbsp;&nbsp;&nbsp; &gt;<br>&nbsp;&nbsp;&nbsp; &gt; I&#39;m wondering how to teach my svn of monodevelop version .14 to not go<br>&nbsp;&nbsp;&nbsp; &gt; looking for .13. I thought getting rid of /usr/local/lib/monodevelop might
<br>&nbsp;&nbsp;&nbsp; &gt; help, but it hasn&#39;t:(<br>&nbsp;&nbsp;&nbsp; &gt;<br>&nbsp;&nbsp;&nbsp; &gt; # rm -Rf /usr/local/lib/monodevelop<br>&nbsp;&nbsp;&nbsp; &gt; # time /home/dalem/bin/monoupdater.sh &gt;t3.txt 2&gt;&gt;t3.txt<br>&nbsp;&nbsp;&nbsp; &gt; $ rm -Rf ~/.config<br>&nbsp;&nbsp;&nbsp; &gt; $ monodevelop
<br>&nbsp;&nbsp;&nbsp; &gt; ERROR: Add-in scan operation failed. The Mono runtime may have encountered<br>&nbsp;&nbsp;&nbsp; &gt; an error while trying to load an assembly.<br>&nbsp;&nbsp;&nbsp; &gt; ...<br>&nbsp;&nbsp;&nbsp; &gt; Scanning file:<br>&nbsp;&nbsp;&nbsp; &gt; /usr/local/lib/monodevelop/AddIns/BackendBindings/ILAsmBinding.addin.xml
<br>&nbsp;&nbsp;&nbsp; &gt; Could not load some add-in assemblies: Could not load file or assembly<br>&nbsp;&nbsp;&nbsp; &gt; &#39;MonoDevelop.Projects, Version=<a href="http://0.13.0.0">0.13.0.0</a>, Culture=neutral&#39; or one of its<br>&nbsp;&nbsp;&nbsp; &gt; dependencies.
<br>&nbsp;&nbsp;&nbsp; &gt; ...<br>&nbsp;&nbsp;&nbsp; &gt; Scanning file:<br>&nbsp;&nbsp;&nbsp; &gt; /usr/local/lib/monodevelop/AddIns/BackendBindings/VBNetBinding.addin.xml<br>&nbsp;&nbsp;&nbsp; &gt; Could not load some add-in assemblies: Could not load file or assembly<br>&nbsp;&nbsp;&nbsp; &gt; &#39;
MonoDevelop.Core.Gui, Version=<a href="http://0.13.0.0">0.13.0.0</a>, Culture=neutral&#39; or one of its<br>&nbsp;&nbsp;&nbsp; &gt; dependencies.<br>&nbsp;&nbsp;&nbsp; &gt; ...<br>&nbsp;&nbsp;&nbsp; &gt; Scanning file:<br>&nbsp;&nbsp;&nbsp; &gt; /usr/local/lib/monodevelop/AddIns/ChangeLogAddIn/ChangeLogAddIn.addin.xml
<br>&nbsp;&nbsp;&nbsp; &gt; Could not load some add-in assemblies: Could not load file or assembly<br>&nbsp;&nbsp;&nbsp; &gt; &#39;MonoDevelop.Core.Gui, Version=<a href="http://0.13.0.0">0.13.0.0</a>, Culture=neutral&#39; or one of its<br>&nbsp;&nbsp;&nbsp; &gt; dependencies.
<br>&nbsp;&nbsp;&nbsp; &gt;<br>&nbsp;&nbsp;&nbsp; &gt; How does monodevelop know to try and load version <a href="http://0.13.0.0">0.13.0.0</a>?<br>&nbsp;&nbsp;&nbsp; &gt;<br>&nbsp;&nbsp;&nbsp; &gt; Any suggestions are very much appreciated,<br>&nbsp;&nbsp;&nbsp; &gt; Dale E. Moore<br><br><br><br>