[MonoTouch] Three20 with additional library projects

Jeff Stedfast jeff at xamarin.com
Fri Jan 13 23:06:26 UTC 2012


Hi Brett,

One thing you could try is adding "-v -v -v -v" to the "Additional mtouch
arguments" text entry box in the iPhone Build section of your project
settings and then look at the build log for the mtouch command-line and see
what exactly the gcc flags are following it are. Perhaps this will lead to
some ideas.

Hope that helps,

Jeff

On Fri, Jan 13, 2012 at 5:07 PM, Brett Spurrier <brett.spurrier at gmail.com>wrote:

> Hi Mono Community,
>
> I have a project which I'd like to have utilize the Three20 framework (I'm
> using the monotouch-binding implementation at:
> https://github.com/mono/monotouch-bindings). I've set up a sample project
> and everything works great. However, my full solution also references other
> libraries (as projects, not precompiled libraries), and when I build
> everything, it build fine. However, when I deploy to the device and run the
> app it crashes on the first site of a Three20 call.
>
> However, it does NOT crash on the simulator.
>
> How can this be? I've tried various combinations of flags and linker
> options, but nothing seems to work.
>
> Again, my app runs fine when my project libraries are include OR Three20
> is included, but NOT both.
> Might anyone have any idea? I'm at a complete loss here.
>
> What information might help debug this?
>
> Cheers,
> Brett
>
>
> _______________________________________________
> MonoTouch mailing list
> MonoTouch at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/monotouch
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/monotouch/attachments/20120113/8aa092e7/attachment.html 


More information about the MonoTouch mailing list