[Moonlight-list] moonlight moon_1.99.7 make tar ball problem ?!

carnev75 carnev75 at gmail.com
Thu Nov 5 06:57:53 EST 2009


2009/11/5 Rolf Bjarne Kvinge <rolflists at ya.com>

>  Hi,
>
>
>
> What is the configure output of moonlight?
>
I have this directory tree:

mcs/
mono/
mono-basic/
moonlight-1.99.7/

the steps I follow:

I have created a parallel mono installation in /opt/mono/ and I have the
version 2.6 of mono. I run the script for configure the environment
variables.
I enter in moonligh-1.99.7/ and type the command:

./configure --prefix=/opt/mono/ --disable-browser-support

I have pasted the output here:

http://pastebin.com/m32d364a6

then I run make and I obtain the error "cannot find metadata file
`/class/lib/net_1_1/Mono.Cecil.dll":

make[5]: Entering directory
`/home/giuseppe/svil/mono/tag/mono-2-6-p1/moonlight-1.99.7/class/tuning/SecurityAttributes'
gmcs -r:/class/lib/net_1_1/Mono.Cecil.dll -debug -r:System.Core.dll
-t:library -out:Moonlight.SecurityModel.dll ./CecilRocks.cs
./PlatformCode.cs
error CS0006: cannot find metadata file `/class/lib/net_1_1/Mono.Cecil.dll'
Compilation failed: 1 error(s), 0 warnings
make[5]: *** [Moonlight.SecurityModel.dll] Error 1
make[5]: Leaving directory
`/home/giuseppe/svil/mono/tag/mono-2-6-p1/moonlight-1.99.7/class/tuning/SecurityAttributes'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory
`/home/giuseppe/svil/mono/tag/mono-2-6-p1/moonlight-1.99.7/class/tuning'
make[3]: *** [all-local] Error 2
make[3]: Leaving directory
`/home/giuseppe/svil/mono/tag/mono-2-6-p1/moonlight-1.99.7/class'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/home/giuseppe/svil/mono/tag/mono-2-6-p1/moonlight-1.99.7/class'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/home/giuseppe/svil/mono/tag/mono-2-6-p1/moonlight-1.99.7'
make: *** [all] Error 2

tnks for help
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/moonlight-list/attachments/20091105/f6920bb4/attachment.html 


More information about the Moonlight-list mailing list